Forums Kongregate

Private Room Helper Userscript (Passwords, Blacklists, Whitelists) page 2

73 posts

Flag Post

Alright, I’ve been using this for a few days now and just noticed something, it seems to be blocking all incoming whispers now. Might be due to Firefox updating to 18.0, or maybe I just never noticed before (since how would I know that I’m not getting them), but it’s definitely something that should be looked into.

 
Flag Post

I can’t see the whispers anymore. All I see is the KongBot notification that the invite has been sent.

 
Flag Post
Originally posted by adv0catus:

I can’t see the whispers anymore. All I see is the KongBot notification that the invite has been sent.

What browser? FF18 as well? I’ll download it and take a look if so in a few minutes.

EDIT Then yay, we can test the update button for it.

 
Flag Post

Chrome 24 on W8.

It’s just randomly happened today. It’s not a confliction with other BK scripts, since I receive whispers normally.

 
Flag Post
Originally posted by adv0catus:

Chrome 24 on W8.

It’s just randomly happened today. It’s not a confliction with other BK scripts, since I receive whispers normally.

Alright. I’m testing with no issues on Chrome 23, so I’m updating. I’ll update FF (which I have never tested the extension on) after that.

 
Flag Post

Just tested on Chrome 24 and FF 18. I could see the PMs on both sides:

EDIT Enabled Chrome chat scripts framework, reg scripts framework, the whispers still show up. Can I get a list of what scripts you are using?

 
Flag Post

A list of what scripts I’m using would require me posting 30+ scripts, so I took the time to fish through and find what’s wrong. Apparently my testing wasn’t thorough enough before, but I now believe that it’s the AFK-command script that’s the issue.

 
Flag Post

That was the cause of my problem as well.

 
Flag Post

I just noticed a bug with the script that caused all moderator users to be blocked after testing it with a few people. To clarify, PMs didn’t appear if they came from moderators but everything was fine if they came from a non-mod user. I’m using Chrome v.24.0.1312.52m and Windows 7.

Here are the scripts I’m using:

- AdBlock
- AFK-command
- Auto-Reload
- Character limit
- Kongregate Chat Timestamp
- Kongregate Chat-scripts Framework

EDIT: It seems the new version fixes the issue.

 
Flag Post

Bump, the script is no longer working after the latest Kongregate update.

 
Flag Post
Originally posted by MadJedi:

Bump, the script is no longer working after the latest Kongregate update.

I just joined chat and someone sent the password [and it worked]. I have a feeling the script no longer works for you because your cookies are getting dumped. I store password, settings, etc in Cookies.

 
Flag Post

It works for me, too.

 
Flag Post

Script broke with the update of faster page loads. I’ve patched that and added a “Force Load PM Script button” that should show up when the script realized that it failed to load.

Problem is that I have no idea how that looks like with K+ since I don’t have it. It could be located somewhere else or not be visible entirely. You can download the update manually (since the update button is hidden :’( ) at either userscripts.org or my own site:

Download It
Download It on UserScripts

Links in the OP work just fine too.


After updating, confirm that your version (boxed in green) is v 1.101 and not v 1.001

 
Flag Post

Odd why isn’t google chrome allowing me to download the script into my extensions?

 
Flag Post

Because it doesn’t trust random site installations. (aka security) You need to download the file (.user.js file extension) and drag and drop that file onto the Chrome extensions’ page.

 
Flag Post
Originally posted by UnknownGuardian:

Because it doesn’t trust random site installations. (aka security) You need to download the file (.user.js file extension) and drag and drop that file onto the Chrome extensions’ page.

Thank you, I got it to work. You’re the best. :D

 
Flag Post

Ah, I should have checked here first! >_<

So do I always have to force the script to load now?

 
Flag Post

It should load automagically as it used to. If it doesn’t, then that is when you need to click Force Load. I’ll patch it up in a week or two and remove the force reload and do automatic checks for when chat loads.

 
Flag Post

Well now I feel stupid for bugging UG in chat about my troubles getting the script working..works like a charm. Thank you once again UG!

 
Flag Post

Thanks, UG! This is amazing! :D

 
Flag Post

hmmm this is a really helpful script indeed. does this works on Opera??

Anyway, i think it will be even greater if we can just tag our people out so that whenever they log in, they automatically goes in our private room wether we’re there or not. Or, it can also be made that invites being automatically sent to those we tag. That way the risk with the private chat password being given to the wrong person is zero, since there’ll be no need for password at all.

That’s just my idea though, but since i’m not a programmer, i can’t create it myself :P

 
Flag Post

That’s something Kongregate would need to implement. At this point, though, it seems like it’s not going to happen any time soon.

 
Flag Post

It’s a good idea. I actually had thought about it before (termed it being “subscribed to a private room”) but there wasn’t any super good way I could check if someone was online and how many times I had invited them (without it seeming spammy on their side) or if they changed games after the invite and missed the link. Just a lot of extra conditions that would make such a thing fairly complex.

 
Flag Post

the only idea i can give to solve that problem is that the invite will be sent to them once everytime they refresh or log in to a game. that way it won’t be spammy, and when they did change game before entering the privat chat room, they will get another invite. i’ve already send a request before to kongregate about that idea, hopefully they think of it as a good feature to be implemented.

 
Flag Post

I seem to have found a bug, seeing as this account is non K+, I saw a “Force script button”

Clicking it many times produced this, though it’s not a big deal, since non K+ can’t use the script anyways