[Redshift] Bugs and glitches (old) (locked)

34 posts

Flag Post

Use this to report any bugs, glitches, or strange things you might find while playing redshift

To start it off: Repairing damage doesn’t seem to effect the hull damage gauge at the bottom of the main screen, yet other times it does change that one but does not change the one in the hanger

Also, the text for hull points goes off the screen and can not be seen, the other bottom row icons can do this as well but only if you approach them from the bottom

I have 110 max fuel, I leveled by using 5 of 7 fuel that I had at the time. I then took a trip for 10 fuel. After which I looked at my fuel and I had 95 fuel. Currently it seems to be: on level restore fuel to max then subtract fuel used in fight. I suspect you want it as subtract fuel used in fight, then restore to full instead.

In the quest derelict, the ship closer to the portal on kruger did not lose its ! after I communicated with it. I was able to finish the quest.

 
Flag Post

In the hangar, my hull points always show as 152/180 instead of the correct total. (Near the beginning of the game.)

 
Flag Post

Mousing over the hp on the main screen puts the tooltip below the game screen and as a result, it isn’t visible.

EDIT: When repairing after you click on an item in the armory, the picture that shows is the item and not the ship. This happened to me with a support item and a weapon.

 
Flag Post

The buttons are still active below the tutorial screen, so it is possible to click on one of those buttons, and get pretty confused, if you click on the tutorial screen to try to get rid of it, as often is the case in MMO tutorials.

 
Flag Post

When you click on an enemy, their health shows as 100% for a little bit before dipping to the appropriate health.

 
Flag Post

Typing something into the chat box and hitting enter has no visible effect.

Quest items are not removed on completion.

 
Flag Post

Very small glitch: it seems like a lot of the flashing brackets around buttons are misaligned.

 
Flag Post

- I’m supposed to drop off the vaccine at the Drop Off Station on Vega. However, there’s no ! above the station:

- I finished training Fuel Optimization Level 2, but still saw 105 as my max (should have been 110). When I opened up the training page, Level 2 was shown with a full bar. I closed it (I don’t remember if I clicked “train” or not) and saw the 110 max as expected, but then I opened up skills again and got this:

For some reason the skill is now at level 3, and partially trained. So it tells me I should have 115 max fuel, but I’m still at 110, even after reloading the page. Not sure what happens next, but something appears to be amiss. (Update: 115 max is now showing, apparently just significantly delayed. I still don’t know how/why I got to level 3 since I don’t think I trained that one manually).

 
Flag Post

The Flash plugin has crashed twice in the past 10 minutes now; I’m using FF7 with Ubuntu 10.10…
I’ve never had this problem with other games – including Tyrant – so… It’s pretty unplayable if this keeps happening – no ideas if others have experienced such problems.

 
Flag Post

The tooltip for reputation gained is half outside of the screen for me.

 
Flag Post

In Thebes, on the derelict mission, I cannot complete the requirement of hailing one of the council cruiser wreckages. The other one works just fine. I can hail the target, but the requirement won’t complete.

EDIT: And apologies for the double post, I forgot I was up there.

 
Flag Post
Originally posted by Phoenix00017:

For some reason the skill is now at level 3, and partially trained. So it tells me I should have 115 max fuel, but I’m still at 110, even after reloading the page. Not sure what happens next, but something appears to be amiss. (Update: 115 max is now showing, apparently just significantly delayed. I still don’t know how/why I got to level 3 since I don’t think I trained that one manually).

Every time you finish a skill, it shows up as partially trained for the next level. It’s kind of like the points bar we have on Kongregate. It shows the total instead of just for the level.

Sometimes, after the objective changes in a quest, the map doesn’t refresh and I have to refresh the page to do the new objective.

On the “get more star tokens” popup, the picture used is for Facebook Credits instead of Kongregate Kreds.

 
Flag Post

I’m supposed to pick something up in Alpha Centauri:

However, I’m in Alpha Centauri and I can’t find anything to interact with. There are no !s, and I’ve tried clicking on everything:

(UPDATE: I left the system and came back and the expected station appeared and I was able to continue, but it was quite confusing at the time)

 
Flag Post

There have been a few times when I scanned things for a quest and didn’t seem to get credit. For example, in this screenshot, I have scanned ships at least 4 times:

I’m not sure exactly what’s going on, but it’s taking my fuel each time I do it too. This is for DLM2:

(UPDATE: Upon exiting the planet and re-entering, all of them went away, suggesting that I was getting credit for them, but that visually they weren’t updating, with !s still above them)

 
Flag Post

“Reaper Arrival” mission tells me to “take this armor and equip it”, but I won’t receive it until I finish the mission. This needs some rewording, or it should be moved to the previous quest as a reward. The item isn’t even armor. It’s a generator.

UPDATE: Detailed information for bug. The picture appearing when you repair is the last item you clicked on in the armory. This should help narrow down the cause.

This last one is me being a bit nitpicky. In Sol (our solar system), if you assume the big mass in the bottom is Earth and one of the other two is the moon, what is the last one?

 
Flag Post

There seems to be a persistent bug where the ship you last attacked doesn’t get properly deselected after destruction. This happens in battles with lots of enemies, but was especially weird here:

In that shot, I have just destroyed the DLM Base, but it is still showing up as a selected target that I can attack in the upper right corner.

 
Flag Post

I can’t exit any menus. The “OK” button is blurred out, and I don’t know what else to do.

 
Flag Post

You know, I have to break everything in a game to be satisfied.

Fully repairing a ship, and deploying a new one after you have the hull upgrade forces you to repair back to full health.

Hovering over the reputation bar after you finish a mission puts it to the left of the reputation bar in such a way that part of it is hidden off-screen.

The description of the mission “Three Prong Attack” has a few errors. Currently it reads: “With, Vesper defeat the first wave of Reapers and collects Reaper signatures…” It should be: “With Vesper, defeat the first wave of Reapers and collect Reaper signatures…”

While collecting the signatures, I also noticed that I already had the required 10, but the mission log did not agree. This is probably because quest items aren’t removed after you finish a quest. I’ve noticed several old quest items in my inventory.

Current Skill upgrade text overlaps the Speed Up button.

The description of the mission “Nice Move There” is another case of a typo. “Impressed with your’re handling of the Risen/Council situation…” Funny thing is, I was already communicating with them for another quest. It also breaks continuity.

 
Flag Post

I need 4400 coins to repair my ship and I have just under 2000. How am I supposed to continue? D:
(Also I don’t have enough star point thingys to get enough money OR any things I can sell to get money…)

Edit: Maybe it would be good to make the ship go to 1hp on failure, so I could grind on level 1s for a while to get money to repair the ship..

Edit Edit: I got enough money from a corrier mission and forgot to repair, so I went to do another mission and went to a supply depot and it let me in the game with 0hp, theres what happened:

 
Flag Post

Also if you have a health adding thingy, and you repair to full and remove it you can have 550/500, or probably even more stupid things which could be beneficial in PVP. (3×50 on the one with 1000hp would be 1150hp, remove the health things (1150/1000) and replace with defence/energy ones- OP)

Also you can repair the ship for minus money :D

Edit: I see there is a thingy that gives +100hp per uhhh.. thing. So if you use this bug ^ you could have +300hp and energy/defence perks too.

Edit Edit: Sorry for the large pictures o.o I thought they would be a little smaller and I’m too lazy to repost them as this is the preview :3

 
Flag Post

When starting the game, the loading screen stops at “FriendModule postinit” – regardless of the browser I try it with. It worked fine earlier today.

 
Flag Post
Originally posted by Ventero:

When starting the game, the loading screen stops at “FriendModule postinit” – regardless of the browser I try it with. It worked fine earlier today.

i have the same problem now

 
Flag Post
Originally posted by Therealtahu:

Fully repairing a ship, and deploying a new one after you have the hull upgrade forces you to repair back to full health.

Wow. Not just this. Logging in will reduce your hp to the amount you would have without hp skills or support slots. Basically, extra HP is useless and it’s just there to drain your credits. This is a major bug that should be fixed asap.

 
Flag Post

I am currently unable to complete the mission ’Gideon’s Edge’ because the shop in that area spawned directly over the station where I collect my rewards.

For the missions where you have to scan multiple items, you can complete it by just scanning the same thing multiple times.

In some multi-part missions (for example, scan a space station and then destroy three enemies), I need to leave the system and come back in order for the enemies to spawn.

 
Flag Post

It appears that there is a stray ! appearing on the armory station in systems that have a quest on the main station: