[Pirate Galaxy] java security error

9 posts

Flag Post

Tried to start the game, got the following error:
`exception: java.lang.SecurityException: Chanigng the SecurityManager is not allowed. `

… does this game do something it is supposed not to do ?

 
Flag Post

Do you have more information about this issue?
What java version do you use, where did you get this exception from?
Feel free to use the “Report a bug” button below the game to report this issue, it would help us to find and fix it.

 
Flag Post

I managed to get a stacktrace.

java version “1.6.0_23”
OpenJDK Runtime Environment (IcedTea6 1.11pre)
OpenJDK Server VM (build 20.0-b11, mixed mode)
Initializing applet…
appargs: partnerId=9 affiliateId=0 campaignId=0 token= secret=kongregatesecret[censored] session=299b[censored]c8 ssuuid=eea5[censored_just_in_case]98 gameId=pirategalaxy
Applet initialized.
Starting applet
java.lang.SecurityException: Changing the SecurityManager is not allowed.
at net.sourceforge.jnlp.runtime.JNLPSecurityManager.checkPermission(JNLPSecurityManager.java:270)
at java.lang.System.setSecurityManager0(System.java:290)
at java.lang.System.setSecurityManager(System.java:281)
at com.splitscreen.launcher.LauncherApplet.start(Unknown Source)
at sun.applet.AppletPanel.run(AppletPanel.java:476)
at net.sourceforge.jnlp.NetxPanel.run(NetxPanel.java:69)
at java.lang.Thread.run(Thread.java:679)

 
Flag Post

Please update your java, your java version is quite old and you should use a newer version. That might also fix your problem.

 
Flag Post

I’m having a hard time finding a browser plug-in (or applet viewer) that will use Java 1.7. I have java 1.7 installed, and I use it for Minecraft, Cartographer, Eclipse and Oracle SQL Developer, but when I go to Sun/Java’s website and ask for the latest browser plugin, I’m told I already have the latest one, and the console says “1.6.0_23”.

I guess I’ll have to wait until Oracle/Sun or OpenJDK publishes a browser plugin that will use Java 1.7 for the VM. (I think Oracle is abdicating to OpenJDK as the reference implementation from 1.7 on anyways.) Might as well close this bug report with “could not reproduce” in the meantime.

 
Flag Post

Easy solution:

1. Go to pirategalaxy.com
2. Go to Game > Download Client
3. Download the stand-alone client that runs from your desktop.
4. IMPORTANT When you run the game, Right-click, and select “Run as Administrator.”
5. The game should load and run as it should!

 
Flag Post

Mozai we are not even using the browser plugin but plain java.
Looks like you have more than one java version installed.

Please check your java and deinstall either all and install the latest again or delete the lower version and keep the newer (I would recommend deleting both and downloading the new one).

Start>Control Panel>Programs>Java>Java>Show>select the ones you want to delete and hit delete/remove.

 
Flag Post

even when i hot run as administrator its stull just endless loads

 
Flag Post

hit*