[Zombie Pandemic] [BUG] People can't join my clan

19 posts

Flag Post

I’m having major problems getting applicants to actually be accepted. Even coordinating with people in kong chat trying to get them in, it’s not working and the interface is giving me contradictory information.

For example, here’s Zoe:

Notice that the “invite to clan” button is not available to be clicked and when I mouseover it I’m told that the “Player has already been invited.”

And yet, when I talk to her to kong chat she says she didn’t get it, and she does not appear on my pending invite list:

So, she applied manually, and she then appears on my “Membership requests” list. I then approve, and she still isn’t admitted to the clan and it still says she’s been invited, but can’t join.

Incidentally, if you look at that second screenshot you’ll also see three players listed on the “Sent invites” list. But the thing is…I didn’t invite any of those players. All three are players who applied, and I approved their applications. But for some reason, they were not entered into the league despite applying and despite being accepted.

It’s been a couple days now that nobody has been able to join my clan.

This is a game breaking problem.


After going through this process a total of three times over the course of 10 minutes, Zoe has finally been successfully admitted into the clan. Why did it take three times? Why do I still have three people who have been approved who still aren’t in the clan?

Flag Post

Not only can i not get into the clan, i cant even get into the game any more.

So much for reset and starting over.


Flag Post

The clan application/invite system can be a bit misleading in its current state. When you accept something in the “Membership Requests” list, it actually moves over into the “Invitations list”. Anything in the invitations list is awaiting the new clan members accept. Acceptance into a clan always ends with the new member accepting the clan approved invitation (or application-turned-invitation). So when you accept an application as clan leader, the applicant is not a member yet, he may have applied and been accepted in several clans, so he has to accept one of them and refuse the rest.

I’m not sure why why the invited person cant see your invitation. If the invite button is disabled as it is in the screenshot, it means a record for the invitation exists in the system. The invited person should be able to see it on the Clan page, I tried it out with no problems. Remember to check both lists (“Invitations” and “Sent Membership Requests”) since a membership request changes to an invitation when it is accepted by the clan. Once the user accepts the invitation, she is entered into the clan but not until then.

So, all this quirkiness aside, are you still having problems getting new members into your clan? Are invitations not getting through? If you are still having problems, I would appreciate it if you would send me a clan name and some character names, so I can check up on it.

Flag Post
Originally posted by IIIHeloIII:
are you still having problems getting new members into your clan? Are invitations not getting through? If you are still having problems, I would appreciate it if you would send me a clan name and some character names, so I can check up on it.

Yes. Some are, some aren’t. So far as I can tell there are three, separate and unrelated problems here:

First: Unresolved, player still can’t get in

See the post before yours from AngelicKitten. She filed a bug report, I filed a bug report, she posted, and eight days later the situation is still not resolved. She made a character by the name of kitten, then after playing for a while realized that the skill system permanently cripples any character who doesn’t invest levelup point into constitution, so she deleted her character via the menu —> settings —> delete user account option with the intent to make a new character.

But now the game is completely bugged for her and she can’t make a new account. Related, after deleting her character she was in my friends list and there was some glitchy behavior on my end for her entry in my list which was still there, but behaving badly. I think I filed a bug report for that as well, though deleting her entry was sufficient to solve that from my point of view.

But she still can’t make an account.

Second: Solved from our point of view, but I suspect this is a bug that could probably be reproduced

I’m not sure why why the invited person cant see your invitation. If the invite button is disabled as it is in the screenshot, it means a record for the invitation exists in the system. The invited person should be able to see it on the Clan page, I tried it out with no problems.

Zoe was a special case that like I said, took 10 minutes of the two of us struggling together in kong chat trying to get her in despite successfully getting half a dozen other people in with no difficulty and no simultaneous chat coordination at all.

I think what happened there…is that I sent her an invite, but rather than accepting it, she accepted a different invite from some other clan then deleted both invite emails. Then she left the other clan and asked me to resend the invite. Which I couldn’t, because it had already been sent. But she couldn’t accept it, because she’d deleted it and joined some other clan. And when she applied manually, I approved, but she wasn’t getting the “accept your acceptance” emails.

Most likely the problem is simply that “invite sent” flags are not being cleared when a player joins a clan, like they should be.

Third: What you described in your post.

Looking at my sent invites list I have four players with pending invites. All four of them are players who applied on their own, and I approved their applications. Three of those players have not logged on in the past week, and have therefore probably just not accepted their acceptance of their application.

The fourth, a player by the name of Kaira, has been logging on regularly, is not listed as being in any clan, and is still in my list.

It’s possible she has simply not accepted her acceptance of her application. I will send her an email. I haven’t done so already because from my point of view there have been so many other problems that it didn’t occur to me that this particular case might be legitimate user error.

So I will do my due diligence in regards to this particular user. Please do your own due diligence in regards to situations one and two above, especially for AngelicKitten who has been wanting to play for the past week but can’t even get into the game.

send me a clan name

Playboy Bunny Babes

Flag Post

AngelicKitten’s problem is another bug related to account deletion, it is currently not working and will just screw up your game data. Maybe I can fix her data manually, so she can play until I fix the bug in the code.

It seems the invite emails you get if you added your email address on the Setting page have links in them that do not work. The links in the private messages you get in-game do work, but not if you already used them or accepted/declined the associated invite on the Clan page. I’m going to remove these links until further notice so players will have to go to the Clan page to accept invitations.

I can tell that Kaira has pending invitations from your and two other clans. You can tell her to go to the Menu → Clan page and look at the Invitations tab to accept or decline, that should always work.

Flag Post

Still no joy here (still cant join). I hadn’t realized that starting over was going to be such a problem.

It said the data would be all gone, which was what i wanted to start over, not that i would have so much trouble rejoining the game. Perhaps a simple, ‘start over’ option somewhere would help avoid replication of this problem, and you can just put a disclaimer in that deleting the account essentially removes you from the game (til you find a long term fix for it.)

it’s too late for me, but maybe other players can learn from my grief.

Flag Post

I expect you can recreate your character sometime tomorrow when the server has been updated with a bugfix I have been working on today. The problem was that not all data was deleted and the data left over is causing errors when you try to recreate your game data with the same id.

I can’t fix your data manually since I don’t know your Kongregate id (its a big number only used in databases) and I cant find it in our system since all your character data is deleted.

So hold on just a little while longer then you will be able to play again…

Flag Post

no worries, been waiting this long, another day wont kill me. Just wanted to let you know the update on my status, incase you thought it was ‘fixed’ i just wanted to let it be known that it’s not, and i am still interested in playing the game.

Thanks for your time and effort on this, it’s appreciated.

Flag Post
Originally posted by IIIHeloIII:

I don’t know your Kongregate id

Go to the user’s profile and mouseover the number listed for their forum posts. It’s in the URL.


Her kong id is 4632478

Flag Post

Thank you for the Id tip, it makes it much easier for me to inspect the data when I’m fixing bugs :)

Flag Post

@AngelicKitten: The bug should be fixed now for everyone who encountered the issue with account deletion and recreation. I didn’t fix your data manually so we can see if the system can handle the weird state your data is in.

Let me know if it works or not.

Flag Post

Still no joy (for me at least), but that may be, because you just fixed it this morning and we need to have the servers reset for the changes to take?

What time do the servers reset any how?

Flag Post

Hmmm, I just tried deleting my kongregate zp account and I could recreate it without problems. I was unable to do thsi yesterday before the bugfix.

Could you try again? Im pretty sure the server is updated and it should work for you too.

Flag Post

no. still no joy.

i suppose what ever happened when i originally deleted, mucked something up really good.

Flag Post

Damn. I just deleted some of your old data manually. Try again.

Flag Post

Still no good, but i suppose i may have to wait for a server update?

Flag Post

The server has been updated twice now during the last couple of days, so that’s not it.

I have deleted more data for your user id, something I thought wouldn’t be an issue but maybe it was.

Please try again.

Flag Post

I see there is a Kitten character for your user id, so I suppose its working again.
Hope you didn’t have trouble getting AtomicKitten as your character name…

Flag Post

Hello, just following up for Kitten. Yes, all is well now. Thank you for your help.

(Funny thing about support, you always hear about problems, you rarely hear any followup once you’ve resolved a problem. :P )

Thanks again.