[Throne of Swords] Bugs

22 posts

Flag Post

Pretty much all multiplayer games have a bug forum, so here’s this ones.

Checked the tavern for today’s set of knights, ended up with 3 almost identical knights, only difference being the 3rd cost 8g per hour instead of 4g like the other 2. They all had the same name and starting stats, level up rates, and bonus abilities but different pictures.

 
Flag Post

I started to build temple but then canceled because I wanted it in different spot. Insted of it dissappearing now I have a ‘fake’ temple in the spot and it can not be demolished. It shows up as the building construction image. When I click it it’s as if it was temple.

So now I can’t have real temple or demolish the fake one to build something new.

 
Flag Post

With 2 level 2 archery ranges, when I train max archers (170) it automatically brings me back down to half (85) this happened several times before I figured out exactly what was happening (I was fine with 167 archers, but upon training the last 3, it went back down to 85).

 
Flag Post

I’m on Firefox 18.0.2. Everytime I want to play I need to quit Firefox and restart it before the game will load, otherwise I get stuck at the Waiting login page.

 
Flag Post

Please actually fix the visit bug. You keep saying its fixed, but the fix only works temporally. This is an important part of the game.

 
Flag Post

I was in a alliance that won a conquest and got the ‘tablets of construction’ item. It lists one of its contents as 10 heartwood tablets, but only gives 5 when used.

 
Flag Post

Every now and then, a building in my main city will spontaneously destroy itself. It will come back as though nothing happened if I leave and reenter, and I believe that it only occurs if a knight destroys a barbarian outpost right around the time that I enter the city.

 
Flag Post

I was upgrading a lumber mill to level 5 and it became a level 1

 
Flag Post

started war academy=>cancelled it=>got lvl 0 war academy that cannot be upgraded/demolished and i cant build new one coz its restricted to 1 building

 
Flag Post

I hired a knight with rarity 6 and cp bonus 34% but he has same ammount cp as others heroes.

 
Flag Post
Originally posted by MegaTherion:

I hired a knight with rarity 6 and cp bonus 34% but he has same ammount cp as others heroes.

The increase in cp will only appear once he has gained a level, and even then only when you are assigning troops to him. At all other times, it will appear as though he has the same cp as an ordinary knight.

 
Flag Post

My game reset. After 3 login try, game loaded and all my work is gone. Game is totally reset to the beginning.

 
Flag Post

hello I beleive this is a bug but it’s not letting me visit peope on my friends list when I press the visit button

 
Flag Post

Here’s another one, or at least I think it’s a bug.
Every time I log on I have 0 or negative resources for everything except gold even though the upper right panel says I should be making a profit on everything. While I stay online the resources grow at what I suppose is the normal rate showed in the above mentioned panel.
Treasures collected while offline do appear as profit, this problem seems to be related to the income from harvesters.
Either it’s a bug or I have a lot of expenditures the game doesn’t report; if so what might those expenditures be?
Note, it’s not from building, haven’t started building anything in a while as this resource problem has been lasting for a couple days.
Note 2: I think it might have started right after I tried a conquest and failed, or at least that’s when I’ve noticed it.
Apologies if this is a silly report, I’m quite knew to the game, so maybe I’m missing something?

 
Flag Post
Originally posted by Psyper:

started war academy=>cancelled it=>got lvl 0 war academy that cannot be upgraded/demolished and i cant build new one coz its restricted to 1 building

have the same issue

 
Flag Post

Right, so I’ve identified what causes the problem I mentioned above.
It seems that if you don’t have enough workers to fully man your harvesters, they cease all production while you’re offline.
The game doesn’t warn that this should happen, so I still consider it a bug.

 
Flag Post

Reporting the tavern resetting bug. Every time I (re)load the game, the tavern resets to 24h.

 
Flag Post

3 sets of bugs:
Visitation, on occasion, seems to break (can’t visit)
Current bug: Diplomacy Points are NOT resetting since 1 Mar, 2013 (last new set was 28 Feb)
Current bug: Chests/Gear. I’ve opened a few chests, they WERE having one item disappears, and appear when next chest opened (and that gear go missing). Now, ALL new gear disappears. Chests vanish (lost a few armor/steeds/weapons as of late)
edit: ?most of? the missing gear has appeared in inventory in the last 2-3 hours.
DP still not reset.

 
Flag Post

Sometimes when a friend helps to complete an upgrade in your main fortress, the building does not get upgraded, and the resources you spent to upgrade it are gone. I’ve had this happen when I tried to upgrade to a level 6 house, and a level 5 Knight’s Hall so far. The Knights Hall hurt, because I’m out the 12 tokens; I can only imagine the pain one would feel if you lost a large stack of much more valuable tokens.

 
Flag Post

I started my above post with Sometimes. I would like to replace that with Recently.

 
Flag Post

I’ve been having issues scrolling up and down in the inventory window.

 
Flag Post
Originally posted by Gendalf31:

Reporting the tavern resetting bug. Every time I (re)load the game, the tavern resets to 24h.

Having the same issue, the timer on the tavern resets to 24 hours count down after every log in.

version 1.8