[BattleCry] Bugs

220 posts

Flag Post

If you see any bugs in game, you are freely to say it here.
This forum is to help the Developer team to inprove any other future games or the current game.

Be sure to say any bugs you find in this forum.
And be free to ask something if you are not sure if it is a bug or not

We in kongregate aprove that people report as fast as possible if there are bugs that lays in this game, Report it!

 
Flag Post

Just a suggestion, use free instead of freely in the bold sentence. A common bug I know I have experienced and other people have too is that you open the game up and you have someone else’s inventory(Their whole army and everything.). Luckily, it fixes itself after a while.

 
Flag Post

I got my friend on Facebook to join, but I didn’t get the, 5000 gold. Please fix this

 
Flag Post

i have some how gotten troops i didn’t have before some already set to armies i have otherwise not yet made, as well as in to my current army, the should have been unable to accept any more units. this happened after a battle would not finish loading(after the actual battle) so i refreshed the page.

 
Flag Post

I logged in, and i had an entirely different army however upon refreshing it fixed its self anyone know how this happend?

 
Flag Post

Ctrl placing and those horse riding units you made during the first act removes them from the game, if you click outside the formation borders.

Normally this will place the unit back, but for me it completely removed it.

I am now down 2 horse units

 
Flag Post
Originally posted by Shurmel:

I logged in, and i had an entirely different army however upon refreshing it fixed its self anyone know how this happend?

It is just a bug that happens sometimes. Refreshing has fixed it for me also.

 
Flag Post

For me when i lose/win a battle i get an infinite Processing screen, i refresh page everytime.

 
Flag Post

bug: when i try to fight a friend it selects the army i have marked in “armies” tab.

reproduce this bug: click armies > click 1st army > click battlefield > fight a friend > in selction screen pick your 2nd army > select fririend’s army > click OK > it will pick your 1st army instead of 2nd.

 
Flag Post

Whenever I start a battle with my second army my ranged units in the back automatically die for no reason. In addition the units spawned by my necron blades also automatically die as soon as they spawn. It’s making it impossible to progress in campaign or in multiplayer with my 2nd army.

 
Flag Post

nevermind I think I found my issue

 
Flag Post

mages dont attack

 
Flag Post

Mages attacks, its not a bug, there is a iten that makes mages take more 50s to cast i think

 
Flag Post
Originally posted by Luis1109:

Mages attacks, its not a bug, there is a iten that makes mages take more 50s to cast i think

which item? are you sure it’s not one that debuff the equiped unit?

 
Flag Post

i had just gone into a ranked match and out of no where the entire enemy army just fell and died before any fighting was shown and also an other time i just gone in and won just as i loaded and there was no enemy army any ideas?

 
This post has been removed by an administrator or moderator
 
Flag Post
Originally posted by Harmenso882:

i had just gone into a ranked match and out of no where the entire enemy army just fell and died before any fighting was shown and also an other time i just gone in and won just as i loaded and there was no enemy army any ideas?

when they all died it may have been because of over abundunce of ultra shield or item with a similar effect and the second one is because of an empty army that is active

 
Flag Post

Whenever I start a battle with my second army my ranged units in the back automatically die for no reason. In addition the units spawned by my necron blades also automatically die as soon as they spawn. It’s making it impossible to progress in campaign or in multiplayer with my 2nd army.

I have this issue too. Archers, gunners and spear-men die as soon as I press play.
I’ve tried making new ones and the same thing happens.

 
Flag Post
Originally posted by aled666:

Whenever I start a battle with my second army my ranged units in the back automatically die for no reason. In addition the units spawned by my necron blades also automatically die as soon as they spawn. It’s making it impossible to progress in campaign or in multiplayer with my 2nd army.

I have this issue too. Archers, gunners and spear-men die as soon as I press play.
I’ve tried making new ones and the same thing happens.

some item reduce your unit defence and without defence they die, so check the effect of every equiped item (especialy legend shields)

 
Flag Post

yea, in a mission at the beggining, it says to make a horsenub, and i do it and says to make 6 but i cant, when i click the triangle nothing happens, i refresh but it doesnt help at all

http://prntscr.com/1ipihn

 
Flag Post

1. I get stuck at “PROCESSING” every now and then. Most likely after I start the game for the first time a day.

2. Sometimes attack animations are skipped, especially ranged ones. I think it only happens if the units are moving.

3. There is a AoE fire attack (2×4?) that gets casted some seconds after the start, wiping out most of my army. MASSIVELY OP…

 
Flag Post

Edit: In general it seems like closed formations are at a disadvantage against all those AoE attacks. That’s quite disappointing.
Maybe making mages a kind of supporter (Buffs, Debuffs, less devastating attacks) would be interesting.

And just another thing that MIGHT be OP: The suicidebomber-thingy… another attack that kills multiple units right at the start.

 
Flag Post
Originally posted by Thorene:
Originally posted by aled666:

Whenever I start a battle with my second army my ranged units in the back automatically die for no reason. In addition the units spawned by my necron blades also automatically die as soon as they spawn. It’s making it impossible to progress in campaign or in multiplayer with my 2nd army.

I have this issue too. Archers, gunners and spear-men die as soon as I press play.
I’ve tried making new ones and the same thing happens.

some item reduce your unit defence and without defence they die, so check the effect of every equiped item (especialy legend shields)

I’ve reduced them to just weapons. Still happens.

 
Flag Post

fighting a person from a friends list > most of time it choose different army than i did selected [it’s annoying, but not game breaking]

 
Flag Post

err i submited it once the reason i’m submitting it second time is that first time there was a simple rule to it it always selected an army marked in “armies” tab.
it no longer follow that rule.