Armory Set Bonuses

10 posts

Flag Post

It appears they are not working if you look at your resources it says 0% armory set bonus, even though I have all silver items.

 
Flag Post

same here

 
Flag Post

Are they all the same level of item? Different levels give different bonuses, and I don’t think they mix.

 
Flag Post

have that same problem armor set bonus dont work ;/

 
Flag Post

Same. Definitely have the same item, and in the armory it says that its on, but before and after resource production is no different, and it is not figured into the collection table.

 
Flag Post

I had noticed this almost 2 weeks ago and sent in a bug report. Nothing has changed since.

 
Flag Post

you have to equip them

 
Flag Post

Thanks there Fedjin.

Let me make the problem we are all having very clear.

I have equipped entire “sets” of items via the armory. The set was located in one row, and was the same level.

In fact, right underneath the boxes where I have the items equipped, it says something along the lines of “10% cash and resources bonus”. It indicates that we SHOULD be recieving the bonus.

I imagine most players stop there, and assume they have the bonus.

However, upon checking my production before and after equipping the proper items, there is NO change. In addition, on the summary report of resources and the myriad of bonuses to our rates of income, the bonus for “equipment set” is zero, regardless of whether or not I have a proper set equipped.

So, please, no one assume that we are not equipping the sets or doing it correctly. I’m pretty sure this function is broken (at least in my game.) Maybe some more people would like to try it out by really checking their resource income rate and not just checking to see if it says you are getting the bonus in the armory, when, in fact, you may not?

 
Flag Post

Yep it’s broken. I took note of my production before and after equipping a full set. Even left the game and came back hours later to see if it maybe just took awhile to register, but it still didn’t work. Full sets are useless.

 
Flag Post

yup sure is broken
another game glitch that kabam refuses to acknowledge or fix…