Can't join Quests I try to assist.

4 posts

Flag Post

Why can’t I assist in all the quests in which I’m invited? I’ve tried to reload and go back to Quests to assist and it doesn’t work. Does someone or something choose which Quests in which I am allowed to assist? Has anyone else had this problem.

I also have a problem with the speed-up button…once I go into the speed-up menu…the free speed-up (under 5 min.)flashes between the actual time remaining and and a much higher amount of time remaining. I have to try to catch it which ends up in my clicking rapidly on the button. Finally I hit on the appropriate time remaining and proceed. It’s very frustrating. Has anyone had this problem?

I’ve tried posting this in the comment option and got no response. I’m not sure where to go with these issues.

 
Flag Post

I am going to write this so even a player who just started would understand, they might find it on a search. I don’t want you to think I am talking down to you. Its kind of like when you call Tech Support and the first question they ask is “IS your computer plugged in and is there power in your house?” :)

To enter a boss quest from chat:
When a red BQ link pops up in chat it will look like this
http://www.kongregate.com/games/DisruptorBeam/game-of-thrones-ascent?kv_origin=/play/join_quest/######### v(1,2,3,4,U)
If you want to help you click the link, this opens a new window. At this point you’ll change to the new window and close the old one. Now you need to change to the volume they tagged it with (or page through the volumes if they didn’t include it) and find the new boss quest (in green). Now click on the tile for the new BQ and then assign your Sworn Sword. now KILL, KILL, KILL, KILL, KILL, wait, rinse and repeat.

To enter a boss quest from in-game invite:
Go to your quest button in your messages and click on on “Accept” until you’ve got them all. Now search the volumes one by one to find the boss quest and click on it to enter, assign your SS and kill kill kill kill kill wait, rinse and repeat

What could go wrong.
1) Where is it? it’s not there.
- You’ve been beaten to the BQ buy others and they have finished it before you have gotten there. in chat this is very common especially in room 1 where there are 200 heavy hitters who pounce on them like a fat kid goes after cake.
2) When I enter the BQ, I can’t assign a SS.
- You’ve gotten the BQ to load, but due to many hitters it doesn’t catch your assignment, keep trying. If after a little while (20 sec or so) you still can’t assign the SS, then others have finished it before you got to the assign SS part. Just close it and it will go away. IF it still stays, then it was lag in updating and just enter it and kill..

anyone can do any boss quest they wish, the only thing holding you back is the speed the page loads compared to everyone else who’s trying and how powerful they are

SPEED UP issue.
Clicking it once will do the job, it will flip back and forth as it checks and double checks the new time. (poor coding for exploit prevention) if you click it more than once, it will confuse things and slow you down.

 
Flag Post

Thank you Aator_Barbarian. I don’t do Chat rooms due to security issues so that explains a lot. The flipping Speed-up has been corrected by the game’s amazing tech crew. thanks! The info on the BQ scavengers is very helpful. I don’t think you are talking down to me. I do click on the Accept button in the BQs but they do not go over to my que. Maybe one will once in a while and I have to be right there and click on it within a half hour. It’s just started being this way within the past two weeks. That’s why I think it is an error in the game.

 
Flag Post

Thank you Aator for this clear explanation :)

@UtherRed: when you have questions/issues, the best options are our official forums and our Customer Support.


Shan – Community Assistant
DisruptorBeam