Infectonator 2

4 posts

Flag Post

Hey guys, I’m having trouble trying to play the game. It says

‘This Kongregate game requires Flash Player version 11 or higher.’

And when I click on the link below..

‘Please update your Flash Player’

I’m brought to Adobe’s website and it says:

‘Your Google Chrome browser already includes Adobe® Flash® Player built-in. Google Chrome will automatically update when new versions of Flash Player are available.’
What do I do?

 
Flag Post

Does clearing your browser’s recent cache help any?

 
Flag Post

So your using Chrome? I assume you are.
Just update Chrome, but if your using another web browser
you might want to check what version of Flash Player you have with that browser.

 
Flag Post

Doesn’t Chrome update automatically?

EDIT: Thanks for your help guys. Guess it WAS an update issue. My browser was facing an update error, so it wasn’t updating for the past few months or so. So I downloaded the latest one and it’s working now.

Thanks for your help guys, much appreciated. :-)