Forums BattleCry

Bugs page 5

201 posts

Flag Post
Originally posted by FC_BRAZIL:

Xonax’s rag must give 40 secs instead of 20

First of all, 20 sec is wrong, it is 20 DEF, and xonax rag is pretty Overpowered in vermin spam so yeah, AND THIS IS NOT A BUG, People can’t read these days , _ ,

 
Flag Post
Originally posted by FlashTom:
Originally posted by FC_BRAZIL:

Xonax’s rag must give 40 secs instead of 20

First of all, 20 sec is wrong, it is 20 DEF, and xonax rag is pretty Overpowered in vermin spam so yeah, AND THIS IS NOT A BUG, People can’t read these days , _ ,

My friend, I meant the survivability of vermins, that were being 20 secs when should be 40, YES it was a bug, apparently fixed now. If you have an armor that benefits your enemy as well and can kill every unit of a type including yours when taken out of the game, it´s not that overpowered. I´ve been short and did not explain that much.
 
Flag Post
Originally posted by FC_BRAZIL:
Originally posted by FlashTom:
Originally posted by FC_BRAZIL:

Xonax’s rag must give 40 secs instead of 20

First of all, 20 sec is wrong, it is 20 DEF, and xonax rag is pretty Overpowered in vermin spam so yeah, AND THIS IS NOT A BUG, People can’t read these days , _ ,

My friend, I meant the survivability of vermins, that were being 20 secs when should be 40, YES it was a bug, apparently fixed now. If you have an armor that benefits your enemy as well and can kill every unit of a type including yours when taken out of the game, it´s not that overpowered. I´ve been short and did not explain that much.

AAAAAAAAAAAND IT IS OVERPOWERED IN VERMIN SPAM!!!!!!!!!!!!!!!!!!!!! And if you post a bug please post properly…

 
Flag Post

Was editing my 500 army and it went into an ifninte save loop. I cannot get off that screen and refreshing does not fix it. Thanks!

 
Flag Post

ahhh was able to fix it by repetely clicking on and other page button between saves. crazy town!

 
Flag Post

oops, no oit didn’t. wehn i retunr to edit screen, it does the save loop again, notletting me acess to my armies. :(

 
Flag Post

My 500 army did this too. Isn’t just the browser, I tried changing. Also changed computer but still broken.

 
Flag Post

i was making my 500 point army then it told me i had 4 super tanks when i only had 1 the same happend with my steam behemoth help

 
Flag Post

Had deleted a unit for my 500 point army, then it keeps constantly saving my 500 point army. also, the 500 point army had 1000 points, and it deleted both units at the same time.

 
Flag Post

Armies are “read” from right to left, so you cannot, as example, use a unit that boost the def of another unit saving it from death at the left side.

 
Flag Post

still stuck in the loop. :P game busted for me.

 
Flag Post

For the 500 point army bug just try clicking reset during the flashes. Should fix it.

 
Flag Post

of course the one most obvious thing to do!!!!! thanks !

 
Flag Post

The hability to “recover HP” from unicorns sometimes is messes up and it adds HP instead to just recover.

 
Flag Post

ah. now it seems that some of my untis vanish wihtout me being able to recover them. so far only seen this in 500 army. tis appears to happen in the edit process, I also have seen the numbers of untis vary (Ex: 1 unit equipedd that i only have enough stuff for one, all the suddfen i have 5). crazy town!!!

 
Flag Post

all seems back to normal after a few refreshes…or was it the daily reset???

 
Flag Post

there seems to be something wrong with army 5!! it keeps switching up my positions of the units and even the units itself! i had 2 thunder mages and 1 fire mage and suddenly there were 2 fire instead! and after i changed it back to how it used to be it shuffeled around again when i started next coop and suddenly i had two demon archers with rhigar instead of 1 and only 2 mages (3 with ultima)! what the fuck is going on???!

 
Flag Post

aalso now whenever i want to join the game that saving loop some people mentioned starts until im somehow able to click reset on army 5… please fix this

 
Flag Post

Glad this got stickied, Well i found a bug, when i use a cultist robe guy in the front, he gets teleported all the way behind everyone

 
Flag Post

Spent hours playing last night building up gold and logged in this morning to find I had lost all of the gold. I had also bought some packs last night and all of them are gone.

 
Flag Post

Same thing happened to me.. I farmed gold all night, I logged out and logged in and saw that my gold is back to 2500..

 
Flag Post

I bought 2 Iron Heroes Starter packs, expecting 20x uncommon and 30x common items, but instead it announces that i have bought the booster pack of the same level but takes my 2600 gold.

 
Flag Post
Originally posted by ShinMori:

Same thing happened to me.. I farmed gold all night, I logged out and logged in and saw that my gold is back to 2500..

Yeah, The saves are a bit rusty…

 
Flag Post

I was deleting units, and it seems to have permamently deleted them out of the items as well. Was selecting one mage unit but it seemed to select both, one remained other has gone completely

 
Flag Post

Hey guys i have an uber problem, i had an amazing army and now when i start the game and it goes to the army screen, its saving uncontrollably i cant even click on anything , my game is ruined , i tried refreshing but nothing worked and i heard some more ppl report this too. help me!!