Force browser to show updated .swf without clearing Cache

18 posts

Flag Post

I am currently testing out my game in preview mode. (on Kongregate of course :-))

When I update to a newer version I have to clear my cache in order for my browser to show the updated version.

The problem is, the saves are only local. So anytime I update the game, in order for the updated game to load I have to loose all local data.

Any ideas or hints on using Kongregate’s “upload new version”?

-Adam

 
Flag Post

1) You can clear your cache without deleting cookies / saved passwords/ etc. Just make sure that only the cache checkbox is checked and nothing else will be deleted.

2) It’s possible that if you rename the game file to a new name everytime you upload it, it won’t be cached. I’m not sure if this will work, but I think it might.

 
Flag Post

Thanks for the response Bob!

Edited
You knew what you were talking about. It is all better now!

 
Flag Post

I’m using Google Chrome and I downloaded an extension “Chrome Gestures”. This allows you to do gestures with your mouse (while holding down RMB). One of the gestures says “cacheless reload” (up down up). But idk how to do it in any other way. If cacheless reload is the thing you’re looking for? I suppose it means it doesn’t use the cache, so yes.

 
Flag Post

I had the same issue long ago. In Firefox just do a full-refresh with CTRL+F5. Worked for me anyway.

 
Flag Post

Edited
Thanks ErlendHL but I was just being dumb :-) It is working as it should.

 
Flag Post

Clearing the cache shouldn’t make you lose your saved games. Can you show me a couple screenshots of the steps you go through to clear it? I’ve cleared mine many times without losing game progress.

 
Flag Post

Wow, I feel like an idiot.

It was NOT the cache deleting my saved games!

Thanks Bob for slapping me in the face and getting me to shut up long enough to see what I was doing wrong :-)

The solution was to simply DELETE the CACHE and NOTHING else. It worked perfectly!

Thanks guys!

 
Flag Post

make sure to back up your file by copy and pasting it somewhere else on your computer first, the desktop works fine.
I am not responsible for those that don’t properly back up their data, and make a mistake and delete their data.

1) download Ccleaner ( I recommend it as a great free fully featured program that deletes all those cookies and crap you don’t need anyway )
2) options – > exclude – > Add – > check drive or folder – > browse – > C:\Documents&Settings\UserName\ApplicationData\Macromedia – > ok
3) run Ccleaner, it will eat up a bunch of stuff (depending on what you tell it you want it to eat) but it will now never delete ANY flash games saves. Unless somehow you put your save somewhere weird. Not sure if thats possible though.

 
Flag Post

BTW, Ctrl + F5 (firefox, although the control key + refresh should work in most browsers) will force a cache reload for that page only.

Occasionally it doesn’t work with swfs, but it’s the first thing I try.

 
Flag Post
Originally posted by Draco18s:

BTW, Ctrl + F5 (firefox, although the control key + refresh should work in most browsers) will force a cache reload for that page only.

Occasionally it doesn’t work with swfs, but it’s the first thing I try.

Yep, hard refresh is my goto for anytime I’m repeatedly testing new uploaded versions.

 
Flag Post

Ctrl+F5 it up. Should work no?

 
Flag Post
Originally posted by feartehstickman:

Ctrl+F5 it up. Should work no?

Nope, doesn’t work.

Originally posted by Draco18s:

BTW, Ctrl + F5

Oh wait.

 
Flag Post


Originally posted by feartehstickman:

Ctrl+F5 it up. Should work no?


Nope, doesn’t work.

Originally posted by Draco18s:

BTW, Ctrl + F5

Oh wait.

Originally posted by DPbrad:

I had the same issue long ago. In Firefox just do a full-refresh with CTRL+F5. Worked for me anyway.

This definitely works.

 
Flag Post
Originally posted by DPbrad:


Originally posted by feartehstickman:

Ctrl+F5 it up. Should work no?


Nope, doesn’t work.


Originally posted by Draco18s:

BTW, Ctrl + F5


Oh wait.


Originally posted by DPbrad:

I had the same issue long ago. In Firefox just do a full-refresh with CTRL+F5. Worked for me anyway.


This definitely works.

We need to go deeper.

 
Flag Post

try ctrl+f5

 
Flag Post

U can’t hide from me LarryTheCoolGuy BabTheCoolGuy

BTW, I think CTRL + F5 would work. Not sure if anyone has suggested it yet or not.

 
Flag Post

Ctrl+Shift+R
Shift+Click(refresh)

combobreaker.png