Flash Develop Having issues

2 posts

Flag Post

I just formatted and reinstalled my operating system recently and when I went to reinstall FD I came to a brick wall of issues concerning usage of the debugger.

Heres what I did.

1. opened new .as file.

2.

 trace("hello world, I AM FLASH DEVELOP!"); 

3. Debug → Start Remote Session

4. “Waiting for flash to connect to debugger” for a solid 5 mins. Then [No debug Flash player connection request].

My External Player Path is set correctly pointing to flashDebugger from the latest flexSDK.
I have the latest Java (but am using Java 6) and adobe flash player.


In order to even get it working as far as it is right now, I had to download JRE 6, and point my environment variable to use the correct Java. (Java 6) because FD uses a .dll file (msvcr71.dll) which has been changed to msvcr100.dll in the newest release of JRE.

Otherwise I was met with the following error. I only mention this, in the event that the error, or my resulting fix for it is causing the very problem I’m experiencing with the debugger.

Debugger startup error: System.DllNotFoundException: Unable to load DLL 'jvm.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at net.sf.jni4net.jni.JNI.Dll.JNI_GetDefaultJavaVMInitArgs(JavaVMInitArgs* args)
   at net.sf.jni4net.jni.JNI.Init()
   at net.sf.jni4net.jni.JNI.CreateJavaVM(JavaVM& jvm, JNIEnv& env, Boolean attachIfExists, String[] options)
   at net.sf.jni4net.Bridge.CreateJVM()
   at net.sf.jni4net.Bridge.CreateJVM(BridgeSetup setup)
   at FlashDebugger.DebuggerManager.Start(Boolean alwaysStart)
 
Flag Post

Try to install Java 7, i think that’s the problem.