lib/fcsh.jar not found

10 posts

Flag Post


I recently downloaded FlashDevelop, and I’m following the flashdevelopmenttutorial to try to learn how to use it. When I tried to run the program, I got the following error:

Exception: Could not locate lib\fcsh.jar in Flex SDK.

(I’m guessing this isn’t a programming error)

I’ve been searching online for answers, the only thing I could find was to uninstall and reinstall FD (which I did, but based on how my program files was still there and how the installation folder was exactly how I left it before uninstallation, I’m guessing it didn’t work as planned). Other than that, I have not been able to figure out what the problem is. I’ve searched through the files, and I’ve found two files named fcsh under the lib folder (not sure if they’re .jar though). I’ve tried copying them, moving them elsewhere, and so forth, but to no avail.

How can I fix this?

(Sorry for remaking a thread that was made a while ago, I found it on google, but the one I found was locked and had a link to another thread about the same topic, but that thread was deleted.)

Thank you very much for your time

Flag Post

Sorry, one other thing I just remembered that might have led to the problem:

I started installing FD late at night, and Flex was taking too long so I cancelled out of it and just installed FD. I installed Flex earlier today, and placed the files into my FD folder, then made another folder within the FD folder, and placed the extracted Flex stuff in there. Could my problem be that I installed Flex later and possibly did something wrong when trying to make another folder full of the stuff? After I uninstalled FD (Which, as stated above, might have failed) and reinstalled it, I installed Flex straight from the FD installation, but not sure if it did anything because my old folder was still in the FD files.

Flag Post

Haha, yeh, sorry about that. I recommended that he install an older version of FlashDevelop which appears to have worked for him. Super interesting error. I might wait to download a new FD/Flex SDK if this bug/problem exists in the more recent versions.

You might try making a thread on FlashDevelop’s site to see if anyone there has an idea of a solution.

Flag Post

I’d do this:

  1. Download the newest Flex SDK and extract it somewhere (doesn’t matter where, it could be in a folder in your documents called Compilers for example).
  2. Open up the FlashDevelop settings menu (Tools→Program Settings)
  3. Click AS3Context on the left and go to the Installed Flex SDKs option
  4. Remove all current SDKs listed by clicking them and choosing remove. Then click add to add a new one.
  5. On the right side of the menu, set the path for the new one to wherever you extracted the SDK to.

  6. Hit okay and close all the menus and you should be good.
Flag Post

Thanks for the replies! I tried redownloading Flex and making a flex folder in documents and using that, but it still gives the same error. Should I try using an older version of Flex? It seems like Flex is the central problem behind all this, so I’m hoping an older version will have what the newer version doesn’t (it’s a longshot, I’m not sure what else to do at this point xD )

Flag Post

Sorry, one final last thingy

I’ve found the fcsh.jar file by searching through the entire C:/. Would it fix my problem if I threw it into my FD File? If so, where should I put it?

Thanks for the continued assistance

Flag Post

Probably wouldn’t. What version of FD are you using?

Flag Post

I’m using 4.2.2-RTM

And Flex’s version is 4.9.0, if that helps any

Flag Post

Don’t really have time to go through the whole thing, but this may be of use:

bool fcshExists = File.Exists(fcshPath);
fcsh = Activator.GetObject(typeof(FlexCompilerShell),"ipc://" + ipcName + "/FlexCompilerShell") as FlexCompilerShell;
if (fcsh != null && !fcshExists) throw new Exception("Could not locate lib\\fcsh.jar in Flex SDK.");

But yeah, make a post on their forums and explain them the issue (or link to this thread). There’s a better chance that someone over there knows how to fix it.

Flag Post

Hmm, try grabbing Flex 4.6 from here instead and extracting that zip somewhere (and then setting it up as mentioned above.) You can always try creating a new project after you do all that too just to be on the safe side.

(I’d also follow Senekis’s advice and make a thread on their site too.)