Adobe Air Application Quitting Automatically

10 posts

Flag Post

An air app compiled under 2.6 installed on a machine with air 3.5 is automatically exiting on application startup.

No errors are thrown, the application simply exits. The only code that would be taking effect at this time is to tell the application to go full screen.

Note: I am troubleshooting remotely. Supposedly Flash, Air, and the app itself were uninstalled and reinstalled to no effect.

Can anyone think of why this would happen?

 
Flag Post

I have experienced such problems several times before. The solution for me turned out to be a very strange one: comment out all the trace calls. Or delete them. I didn’t research this issue further though and don’t know whether this is your case too.

 
Flag Post
Originally posted by BrainStormer:

I have experienced such problems several times before. The solution for me turned out to be a very strange one: comment out all the trace calls. Or delete them. I didn’t research this issue further though and don’t know whether this is your case too.

Does targeting release mode solve this issue?

 
Flag Post

If the solution is to comment all trace calls, then remember that you can just find strings containing trace(*); in all files, replacing with the commented version

 
Flag Post

Does targeting release mode solve this issue?

I didn’t quite catch of what you said. What is a targeting release mode?

 
Flag Post

Here’s the thing:

It works on every single machine we have access to testing on.

It works on the client’s laptop.

It won’t work on the ginormous monitor touch-screen machine that was intended for the setup, yet a prior version worked last week (same publish settings) although now it doesn’t.

 
Flag Post

Could it be a problem with that machine then? Something is causing an obscure problem with Flash/Air?

Otherwise, is it just another instance of Flash not working for an unknown reason.

 
Flag Post
Originally posted by feartehstickman:

Could it be a problem with that machine then? Something is causing an obscure problem with Flash/Air?

Could be. But I don’t know.

 
Flag Post

Have you tried making a different air application to see if it also crashes, or if it is specific to yours?

 
Flag Post
Originally posted by Drakim:

Have you tried making a different air application to see if it also crashes, or if it is specific to yours?

We attempted to reinstall the beta (which had previously worked) and that program also experienced the same behavior.

With limited access to stuff to send to the client, other air applications were not tried. My coworker is on a plane flying out to the client now to “WTF” at them (carrying a backup tower, to boot).