IMPORTANT: Chrome and savefile loss

78 posts

Flag Post

If you use Google Chrome to play Anti–Idle and wake up seeing yourself at level 1 or the Data Transfer Process thing, switch to another browser immediately. Your savefile should still be there.

An official fix for this issue is yet to be discovered. In the meantime, you can try this to see if it works for you:

Originally posted by GuzsikDavid:

GUYS!! I FOUND THE SOLUTION! (at least it worked for me)

The problem is possibly due to a chrome update that went wrong, and now you have 2 flash players installed. In case you didn’t know, chrome uses integrated flash instead of the downloadable one. Now the recent update forgot to delete the older version of flash, and now the 2 installs conflict. You have to disable the older version, here’s how:

Navigate your browser to chrome:plugins and follow these steps:
Click on details as shown below: (don’t mind lingual differences)

Find the old version (anything that is not 11,3,300,268), and click disable/turn off, leave the latest version as-is.

Then, restart your browser. You may have to set the data storage to unlimited again.
Right click on the game screen, and select Settings… then go to the tab with the folder on, and drag the slider all the way to the right (until it says Unlimited).

Any other games that you have played on kongregate may also not work, this fixes them as well.
Hope this helps in most cases.

 
Flag Post

For me, it is not saved on any browser. I’ve checked IE and Firefox but there’s nothing there.

 
Flag Post

I use Chrome – it is in fact more reliable than Firefox and IE, and far faster than the others.

 
Flag Post

I had to restart my file, but only because i botched the testing file transfer.

 
Flag Post
Originally posted by piqj105:

I had to restart my file, but only because i botched the testing file transfer.

What level were you?

 
Flag Post

Now I can’t play, because I just won’t switch my browser for just a game…
There really should be a fix for that.

 
Flag Post
Originally posted by GuzsikDavid:

Now I can’t play, because I just won’t switch my browser for just a game…
There really should be a fix for that.

You don’t have to switch your browser just because of AI. Simply run AI in a different browser, and continue on as normal.

 
Flag Post
Originally posted by arit3:

I use Chrome – it is in fact more reliable than Firefox and IE, and far faster than the others.

Obviously not if there is a known issue with Chrome and AI.

 
Flag Post

let’s NEVER go through that again… :<
(I shamefully admit that if mozilla hadn’t saved me, I would’ve just given up at level 1050)

 
Flag Post

Someone in the other chrome thread has posted (supposedly) a fix and gave the cause for this:

Thanks to GuzsikDavid for this. I did not make this

Originally posted by GuzsikDavid:

GUYS!! I FOUND THE SOLUTION! (at least it worked for me)

The problem is possibly due to a chrome update that went wrong, and now you have 2 flash players installed. In case you didn’t know, chrome uses integrated flash instead of the downloadable one. Now the recent update forgot to delete the older version of flash, and now the 2 installs conflict. You have to disable the older version, here’s how:

Navigate your browser to chrome:plugins and follow these steps:
Click on details as shown below: (don’t mind lingual differences)

Find the old version (anything that is not 11,3,300,268), and click disable/turn off, leave the latest version as-is.

Then, restart your browser. You may have to set the data storage to unlimited again.
Right click on the game screen, and select Settings… then go to the tab with the folder on, and drag the slider all the way to the right (until it says Unlimited).

Any other games that you have played on kongregate may also not work, this fixes them as well.
Hope this helps in most cases.

 
Flag Post
Originally posted by arit3:

I use Chrome – it is in fact more reliable than Firefox and IE, and far faster than the others.

I how you morons feel it’s so important to let everyone know how much better your choice of browser is when the topic is about there being a save file deleting bug when using said browser.

I’d love to what posts your knee-jerk reaction to feel superior to people would lead to in the event Chrome had an issue where it was sending all the sites you visited to a third party.

 
Flag Post

Just followed ChaosNinja’s advice up there, and it worked for me.

I’m glad too, since I hadn’t backed my save up for a thousand levels or so.

 
Flag Post
Originally posted by JDude151:

Just followed ChaosNinja’s advice up there

I didn’t make that, someone else did. I need to put a notice…

 
Flag Post

Great that there’s been a fix, but I’d still like to urge people to not use Chrome. This is not the first time Chrome has randomly gotten a problem. Remember when it would refuse to register key input?

There also seems to be a memory leak with AI and Chrome, that leads to lag after a while. I’ve not had this issue with any other browser. Oh and, IE isn’t a great idea either.

 
Flag Post

this is why I don’t feel comfortable using Chrome, things like this happening.

 
Flag Post
Originally posted by SoStacieFan:

this is why I don’t feel comfortable using Chrome, things like this happening.

Yeah Chrome always has issues with flash games.

 
Flag Post

Anyway I can transfer my test file from megaswf over to ai? It’s a months worth of difference.

 
Flag Post
Originally posted by Clams:
Originally posted by arit3:

I use Chrome – it is in fact more reliable than Firefox and IE, and far faster than the others.

I how you morons feel it’s so important to let everyone know how much better your choice of browser is when the topic is about there being a save file deleting bug when using said browser.

I’d love to what posts your knee-jerk reaction to feel superior to people would lead to in the event Chrome had an issue where it was sending all the sites you visited to a third party.

Just as you apparently feel it’s so important to let everyone know how superior you feel that your opinion is, or how dumb you think they are? Please. Leave the drama for private venues. This topic isn’t about how you think chrome sucks, or how you feel the need to (weakly) flame people for their choice of browser/pride in their choice.


That said, nice to see a fix. I used to use chrome pretty much exclusively for flash games since it was lightweight and I preferred to use my then limited ram on Firefox, as I prefer a more powerful and customizable browser. I’ve since switched to Seamonkey for AI now that I have more ram, but was using Chrome to test Triangle Apocalypse. Thanks GuzsikDavid for sharing.

Edit:

Originally posted by midfield99:

Anyway I can transfer my test file from megaswf over to ai? It’s a months worth of difference.


That’s kinda unrelated to the topic at hand, but no, you can’t. The first post of the Triangle Apocalypse Open Testing thread says as much, I believe.

 
Flag Post

“An official fix for this issue is yet to be discovered.”

Wrong.

We in Anti-Idle Room #1 have found a fix that works 100% of the time.

If you login using Chrome and your save is reset, copy your antiidle .sol file to somewhere easy to find, like the desktop. Then navigate to C:\Users\your login\AppData\Local\Google\Chrome\User Data\Profile 1\Pepper Data\Shockwave Flash\WritableRoot\#SharedObjects\GKUBHE2G\chat.kongregate.com

Replace the corresponding antiidle .sol file into this folder and restart your chrome browser. It should load your game no problem. No additional steps with flash plugins or any other nonsense are required.

This is also where chrome will now be storing your Anti Idle game saves, take note on this. This will be the location you will be backing up and restoring your save file from now.

Thank you Tukken for your awesome game and amazing Chrome guide.

 
Flag Post

But now what if you want to go back to Firefox? The one currently in the first post is “better”, in my opinion. But note how yours still isn’t official though. And “GKUBHE2G” is still [random numbers/letters].

 
Flag Post

To all:

I am sorry for being snobbish on the forums, and will not do that again.
Also, I too am the victim of the double-flash-plugin syndrome, and david’s idea helped a LOT.

Thank you.

 
Flag Post
Originally posted by black1abel:

“An official fix for this issue is yet to be discovered.”

Wrong.

We in Anti-Idle Room #1 have found a fix that works 100% of the time.

If you login using Chrome and your save is reset, copy your antiidle .sol file to somewhere easy to find, like the desktop. Then navigate to C:\Users\your login\AppData\Local\Google\Chrome\User Data\Profile 1\Pepper Data\Shockwave Flash\WritableRoot\#SharedObjects\GKUBHE2G\chat.kongregate.com

Replace the corresponding antiidle .sol file into this folder and restart your chrome browser. It should load your game no problem. No additional steps with flash plugins or any other nonsense are required.

This is also where chrome will now be storing your Anti Idle game saves, take note on this. This will be the location you will be backing up and restoring your save file from now.

Thank you Tukken for your awesome game and amazing Chrome guide.

While it does work, I don’t consider it to be a fix. It just transfers the data to the built–in Chrome’s Pepper Data, and can’t be shared with other browsers, and it might switch back to the old save suddenly for any reason. With Chrome, you’ll never know.

 
Flag Post

Help! How to fix this problem? it seems to be happen on mine too. :(

 
Flag Post

The plugin disable/enable solution still has you looking for where to place your save file :p. Just use Tukkun’s quoted post ‘cuz the plugin disable still has you digging through all places to get your save file in place :/. I have yet to figure out where to place it for chrome’s NON-Pepper data :/.

 
Flag Post

changing browsers worked for me!