Unity games don't submit badges.

10 posts

Flag Post

So I have a problem with unity badges being submitted.
The problem is isolated to unity games, normal flash games badges work fine.

The problem is not with the API, I log into the chat, and I have the little green box, so the system knows I’m logged in, just when I get the criteria for badges nothing happens.

I have played a few games, and the problem persists. I have played and completed Save Toshi, and the new Accelerator game. Neither gave me the badges.

If anyone knows any reason why this may be happening, I would be greatly appreciative.

Thanks :)

 
Flag Post

Well, I think you can just Report The Missing Achievement.

 
Flag Post

Refreshing the game and retrying for the badges again works for me. Annoying, but it only takes an extra minute for most.

True though, this only happens in Unity games.

 
Flag Post

I’ve refreshed, replayed, refreshed, replayed again and again.
The badges just DON’T want to submit.
Not only that, but statistics in general don’t submit. I click on my hi-scores for unity games and the API hasn’t registered anything.

It’s like the connection between the game and Kongregate’s server is broken.
But it is strange because like I said, flash games work perfectly. Badges and statistics submit normally and consistently.
Unity games, however, haven’t managed to submit even one statistic.

 
Flag Post

Do you have any background programs running? I forgot to mention that I had to turn mine off before restarting.

 
Flag Post

Well just regular background programs.
Other than my McAfee security nothing else is network related and would conflict.

But flash works, and the little green box is showing, like I can chat during unity games, just the score doesn’t submit.

If there’s a problem it’s unity specific.

 
Flag Post

Again I tell you, Report The Missing Achievement..

 
Flag Post

Well, make sure to turn off any firewalls you got on. If it doesn’t work, you might wanna try another browser?

 
Flag Post

This happens to me on every single unity game as well. Has anyone identified what happens, or are there any logs I can submit to help track this bug down? Even redoing the badges doesn’t work for me, I have to submit the missing achievement email each time. I show the green plug too.

 
Flag Post

Same here. I have Firefox, but nothing blocking it (allowed through NoScript).

I just don’t get badges on Unity games. All other games work fine.