cant stop moving diagonally even when hands away from keyboard, help!

7 posts

Flag Post

in some unity or other games where you move a character (mainly 3D) such as island escape beta i wont stop moving sideways when not pressing anything, have tried many solutions but none work

 
Flag Post

Trying pressing the key that makes the character go that way.

 
Flag Post

i tried, it didnt work, but today i noticed im moving diagonally down left, opposite of before…

 
Flag Post

have found that when in looting menu in island escape beta if i press and arrow key of either right or left i start moving that way! i hope it helps

 
Flag Post

nm, it turns out that if i push the key for a while in a direction it goes that way and only left or right

 
Flag Post

This is a program focus issue. Many times when you press an arrow key and the game frame loses and regains focus, it acts like the key is always being pressed until you press it again. This applies to multiple applications including Flash, Unity, and Java. Depending on whether or not you can replicate it on other games might mean it is a problem with the game code itself.

 
Flag Post
Originally posted by bowtiesarecoo1:

in some unity or other games where you move a character (mainly 3D) such as island escape beta i wont stop moving sideways when not pressing anything, have tried many solutions but none work

Sounds like sticky keys. Do you use Internet Explorer?


Edit: I’ll be leaving later today, and IE is the most common browser of sticky keys; so I’ll go ahead and tell you step-by-step how to fix it!
There’s several ways, the first way being:

  1. Go to ‘Tools’
  2. Next, go to ‘Internet Options’
  3. Then ‘Security Tab’
  4. Uncheck protected mode.

And if you don’t feel safe clicking it, you can add Kongregate to your trusted sites and still have protected mode on.

  1. Go to ‘Tools’
  2. Next, go to ‘Internet Options’
  3. Then ‘Security Tab’
  4. Click trusted sites
  5. Click sites
  6. Uncheck require server
  7. Click add, then add www.kongregate.com
    • Make sure you have unchecked protected mode for this entry. This will disable it only for Kongregate.