Fix for Keys sticking in Games in Internet Explorer page 3

142 posts

Flag Post

If it still isn’t working, maybe you can switch to another browser such as Mozilla Firefox.

 
Flag Post

A quick fix is to just use firefox – it’s free and it has no problems, I prefer IE but I use firefox for games that I need to.

 
Flag Post

works but you may get the trojan js.renos, so becareful.

 
Flag Post

I used Opera to get the games to work. I would prefer to keep using IE if possible, but thanks for all the help.

 
Flag Post

does it make a difference with chrome???

 
Flag Post

This doesn’t work in Chrome because it doesn’t have that problem.

 
Flag Post

What with the recent virus escapade, I’d just totally steer clear of IE for a while.

 
Flag Post
Originally posted by Phoenix00017:
Thank you bbiernat for this fix that seems to work well for most people in IE8 who have problems with keys "sticking" in games. Note, if your key is physically sticking that's your fault for spilling Coke on it. But if it's only virtually sticking, this should help.
Originally posted by bbiernat:
SOLVED:

Tools---Internet Options --- Security tab --- uncheck protected mode.

or

Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add.

This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem.

Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4.

Good Luck!
This alternate fix was also proposed:
Originally posted by amtie:

I had this problem for a few days now. I came upon this thread, and tried the protected mode fix, and I got multitask to work perfectly. However i didn’t like the lowered security. I turned protected mode back on, and tried playing multitask again, and, no surprise there, my keys stuck. However, when i tried to run my browser (IE8) as administrator (right click on quicklaunch button – run as administrator), even when you go to the security tab and check the “protected mode” and restart the browser, you can play games without the keys sticking. However, by merely running IE8 as an admin, i get the “protected mode: off” status on the bottom, even when i checked that it was on in the Security tab. I also get no security warning (yellow bar on top). You might prefer running your browser as an admin rather than reducing your browser’s security for a few games. It’s not worth it.

Comp specs:
PC Vista Ultimate 32-bit
4GB RAM (~3GB actual)
Quad-core 3GHz
2 Nvidia 8800GT (SLi) GPUs (not required for flash)

I found that even the slightest lag in game, either from particles, animations, or processing, the keys would stick. This glitch is most prominent in B29 Assault. Hopefully my info helped.

[Hijacked by Ventero - Adding some keywords so the search function hopefully finds this thread when searching for a fix: WASD arrow keys sticking stick sticky moving moves]
It won't work. It showed an error saying that it has to be *https://* instead of *http://*, but luckily it works on Windows XP though.
 
Flag Post

If you uncheck the checkbox, http:// URLs should work fine.

 
Flag Post

Since this forum was revived anyway…

Originally posted by notverygood:

What with the recent virus escapade, I’d just totally steer clear of IE for a while.

I’d just totally stay clear of IE. I mean, the thing is a centre for viruses. Mozilla Firefox, or even Google Chrome is MUCH more secure. If you seriously use the internet (more than an hour a day) you should not use IE, as you are likely to get a virus.

 
Flag Post
Originally posted by sellyme:

Since this forum was revived anyway…

Originally posted by notverygood:

What with the recent virus escapade, I’d just totally steer clear of IE for a while.

I’d just totally stay clear of IE. I mean, the thing is a centre for viruses. Mozilla Firefox, or even Google Chrome is MUCH more secure. If you seriously use the internet (more than an hour a day) you should not use IE, as you are likely to get a virus.

+1

 
Flag Post
Originally posted by Phoenix00017:
Thank you bbiernat for this fix that seems to work well for most people in IE8 who have problems with keys "sticking" in games. Note, if your key is physically sticking that's your fault for spilling Coke on it. But if it's only virtually sticking, this should help.
Originally posted by bbiernat:
SOLVED:

Tools---Internet Options --- Security tab --- uncheck protected mode.

or

Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add. *It didn't work for me*

This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem.

Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4.

Good Luck!
This alternate fix was also proposed:
Originally posted by amtie:

I had this problem for a few days now. I came upon this thread, and tried the protected mode fix, and I got multitask to work perfectly. However i didn’t like the lowered security. I turned protected mode back on, and tried playing multitask again, and, no surprise there, my keys stuck. However, when i tried to run my browser (IE8) as administrator (right click on quicklaunch button – run as administrator), even when you go to the security tab and check the “protected mode” and restart the browser, you can play games without the keys sticking. However, by merely running IE8 as an admin, i get the “protected mode: off” status on the bottom, even when i checked that it was on in the Security tab. I also get no security warning (yellow bar on top). You might prefer running your browser as an admin rather than reducing your browser’s security for a few games. It’s not worth it.

Comp specs:
PC Vista Ultimate 32-bit
4GB RAM (~3GB actual)
Quad-core 3GHz
2 Nvidia 8800GT (SLi) GPUs (not required for flash)

I found that even the slightest lag in game, either from particles, animations, or processing, the keys would stick. This glitch is most prominent in B29 Assault. Hopefully my info helped.

[Hijacked by Ventero - Adding some keywords so the search function hopefully finds this thread when searching for a fix: WASD arrow keys sticking stick sticky moving moves]
It doesn't work. The glitch still happens
 
Flag Post
Originally posted by RNGbladegames:
It doesn’t work. The glitch still happens

Firefox and Chrome.

 
Flag Post

Both of em. i fixed the problem. it happens on My mum’s vista and dad’s 7. Doesn’t seem to happen. Even when I put what you put on for Windows XP…

Originally posted by SavageWolf:
Originally posted by sellyme:

Since this forum was revived anyway…

Originally posted by notverygood:

What with the recent virus escapade, I’d just totally steer clear of IE for a while.

I’d just totally stay clear of IE. I mean, the thing is a centre for viruses. Mozilla Firefox, or even Google Chrome is MUCH more secure. If you seriously use the internet (more than an hour a day) you should not use IE, as you are likely to get a virus.

+1

I don’t agree. I haven’t had viruses on Internet Explorer yet I use Internet Explorer just to play Stick Arena on Xgen Studios and Firefox I use alot after a problem with youtube on Chrome.

 
Flag Post

k, i dont know what to do for firefox, this is only for IE8

 
Flag Post

If keys are sticking in Firefox you have another problem, most likely a hardware issue (as in, your keyboard is the problem).

 
Flag Post

oh yeah, i got the problem fixed. just change around the keys and u will be fine

 
Flag Post

Yes, this may work but is there any way to do this WITHOUT putting your computer at risk?

 
Flag Post

Also there is when i play this game on another website how come it workes there? (excsept sydney shark thats an in-game problem)

 
Flag Post
Originally posted by zhella:

Yes, this may work but is there any way to do this WITHOUT putting your computer at risk?

Kongregate does not pose a risk (and ‘trusting’ the sites does not magically remove all security measures), but if you really don’t want to do it, you’ll have to switch to a different browser.

 
Flag Post

Still doesn’t work! neither does i tried it on Lethal war zone and all i got was my camra shoved up against the wall its either an update from the website or the game, thought i dont think its the game because it happens o any other game i play. any one want to excplain that to me?

 
Flag Post

Il try that too…

 
Flag Post

Help! I have IE7 with the same problem. I checked the security tab in internet options, but there is no ‘protected mode’ box. I don’t know what to do!

 
Flag Post

Try these instructions.

 
Flag Post

is there a fix for this in firefox? got the newest version; my problem is the key sticks for about 2-5 secound which can really fuck up the game your playing.. happens about every 1-2 mins..