For Chrome Users Having Trouble With Keyboard and Flash Games

9 posts

Flag Post

Recently ran into this problem on Chrome, that is apparently a long time issue that comes and goes with various Chrome updates.

In some games, the keyboard controls are either partially working, works at first then stops, or doesn’t work at all. It’s really annoying, but I found a fix.

1.Click wrench icon in Chrome
2.Options
3.Under The Hood
4.Content Settings
5.Disable Individual Plugins (in the Plug Ins area)
6.Click blue +details button on right
7.There are 2 flash files
8. Disable the one that ends with gcswf32.dll, and enable the other one.

This bypasses Chrome’s built in flash player, and lets you use Adobe’s non-Chrome one (fixing the keyboard controls problem). You might get a message after restarting browser to download Adobe’s flash, but it takes a few seconds.

Sorry if this has already been brought up, but noticed a lot of game comments having this problem, and wanted to share the fix.

 
Flag Post

Added to the FAQ. Thanks!

 
Flag Post

Outdated. Chrome has since moved its options and Under the Hood tabs from the wrench drop-down menu. Is there any way to work around this?

 
Flag Post
Originally posted by Calcium11:

Outdated. Chrome has since moved its options and Under the Hood tabs from the wrench drop-down menu. Is there any way to work around this?

It’s now been moved here:
1) Click the wrench icon.

2) Click “Settings”.

3) Then at the very bottom at of that page click “+ Show advanced settings”.

4) Under the heading “Privacy” there is a box that says “Content Settings”. Click it.

5) Scroll down the box that appears until you find the heading “Plug-ins”.

6) Under that heading there are four options, which are “Run all”, “Click to play”, “Disable all”, and “Manage exceptions”. Below those is a link that says “Disable individual plug-ins”. Click that.

7) In the top right-hand corner there is a link that says “+Details”. Click it

8) Follow TheyCallMeTroll’s instructions as of number 7. (For ease of reading I’m putting them here. Also it’s been edited because certain things have changed from when the original post was created.)

9) Locate the flash files. Disable the one that ends with “gcswf32.dll” (I assume this stands for something like “Google Chrome Shockwave Flash for 32 bit”) , and enable the other one. (For this to work you must have Adobe Flash installed directly from the Adobe website.)
Or you could type into the omnibox “about:plugins” minus the quotes, and follow from number 7 in my post.

N.B.: I was on linux while writing this so I have not tested if the DLL is still the same. However the way to get to the plug-ins area is the same across all operating systems.

ETA: Tested on Windows 7 Ultimate 32 bit SP1.

 
Flag Post

Alright so I have three flash plugins what do I do then?

 
Flag Post

I’m using the latest version of chrome (version 23.0.1271.95 m) on Windows 7 Home Premium 64-bit SP1 and i don’t not have file ending with “gcswf32.dll”. i do have a file with the ending “NPSWF32_11_4_402_287.dll”. i disabled that to see if it would work, and there was no change.

Edit: the keys work if i hold Alt while pressing them.

 
Flag Post

Same issue as MrUgly1000. I disabled the other one (pepflashplayer.dll) and it seems to be working fine now. So follow the above instructions, but replace the “gcswf32.dll” with “pepflashplayer.dll.” Hope that helps

 
Flag Post
Originally posted by MadTick:

Same issue as MrUgly1000. I disabled the other one (pepflashplayer.dll) and it seems to be working fine now. So follow the above instructions, but replace the “gcswf32.dll” with “pepflashplayer.dll.” Hope that helps

i tried that too and it didn’t work for me. keys still won’t respond without holding alt first.

 
Flag Post

My problem is that, for a lot of games, all the controls work, but whenever I am moving right using the right key (or any directional key), when I stop pressing the button, it still moves in that direction as if I am still pressing the button. It makes so many games unplayable. And yet, not all games do this. Is there a way to fix this?