The mystery of the missing save games

8 posts

Flag Post

I noticed this about a month ago, that for some reason my save game in gemcraft labrynth was gone. and i saw some comments “try it in another browser”. So i closed down chrome and loaded up the dreaded IE. And low and behold my save was still there. So i just played this way for a while. Checking back every few days to see if Chrome was working again or not. And it still wasnt. So i decided to try a few things.

I backed up my GCL save, then deleted the originals. Which would force chrome to make new saves. So i loaded up the game, made a new save file, and played a map to ensure that it saved the data. And went back to the usual place…

c:\users\name\AppData\Roaming\Macromedia\#shareddata\<gibberish>\chat.kongregate.com\

and found…nothing. there were no GCL saves. So i loaded up the game again to see if my save was gone. And no it was still there. So Chrome was still saving…but where? that was the question. So i did a system search and found…

C:\Users\name\AppData\Local\Google\Chrome\User Data\Default\Pepper Data\Shockwave Flash\WritableRoot\#SharedObjects\GHJRAFS4\chat.kongregate.com

…so i copied my backed up save to this folder, and boom, my old save was back and usable in chrome, BUT will likely no longer be accessible in IE and FF. So its up to yall whether this helps.

 
Flag Post

One of Chromes latest updates meant that game data is saved differently in Chrome compared to other browsers, since Chrome uses a different Flash Player (or something along those lines). There’s nothing that Kongregate can do about it, except wait to see if Chrome will possibly do anything about it. You could try doing this to see if it helps for other games.

 
Flag Post

oh this wasnt asking a question. I have seen alot of other people asking where there save games went, figured i would post my findings.

 
Flag Post

Really appreciate the post Tom, thank you. Could you perhaps explain a bit more? Break it down in a step by step method so it’s easier to follow for those of us who haven’t investigated this change too closely?

Maybe my brain is working a bit slow seeing that it’s Monday but I went to my C:\Users\<name>\AppData\Local\Google\Chrome\User Data\Default\Pepper Data\Shockwave Flash\WritableRoot\#SharedObjects\<gibberish>\chat.kongregate.com\ folder found only a directory named 0000. No other folders. I navigated over to my game_files in AppData and found several folders but copying the folders back to the chrome location didn’t seem to help. Do you have to let chrome make a folder location first (since every game seems to create a gibberish name for each game) and THEN copy the .sol file from AppData? Will that created folder be deleted every time a game is exited?

Also, my save data seems to be at c:\users\name\AppData\Roaming\Macromedia\#SharedObjects\<gibberish>\chat.kongregate.com\

Thanks again for your time posting your explanation.

 
Flag Post

You can read an alternate explanation here. As for your question, your folder will not be deleted when your game is closed unless you run a cookie-cleaning program.

 
Flag Post

I’m still having trouble here. I’m copying every file located here:

C:\Users\Andy\AppData\Roaming\Macromedia\Flash Player\#SharedObjects\KASDJD4L\chat.kongregate.com

And pasting them here:

C:\Users\Andy\AppData\Local\Google\Chrome\User Data\Default\Pepper Data\Shockwave Flash\WritableRoot\#SharedObjects\DVKYBV3A\chat.kongregate.com

Included full path to ensure I’m doing this right.

I must be missing something because the methodology seems strange to me. Today I play Monsters’ Den Chronicles for a few hours. Closed the tab, went back to the game later and lost everything. I tested to see if the above method fixed anything but I lost ALL progress as soon as the game is exited.

To test: I enter the dungeon and loot something and then leave the dungeon. Progress is automatically saved. I can verify this by going to the main menu, selecting my party, and then reentering the dungeon. I have the same gold, xp, and equipment as when I left the dungeon.

However, when I close the tab and try to reload the game, all progress is gone. The reason why I’m confused is where does my saved data go? To the old flash location? Does that mean I have to move it to the new Pepper Data location every time before I quit? Or should it be saving in the new Pepper Data location?

I’m probably just missing something crucial but it sucks playing a game for hours with no progression being saved. I’ve tried other games and find the same results. Once I leave the page, the data is gone.

 
Flag Post

Ugh, further research shows that some games save fine on Chrome, but others do not. Relic of War saves my progress fine. Super Adventure Pals does not. Almost appears random, but I’m sure it has to do with some games working fine with the new way that Chrome handles flash saved data and some games don’t play well.

This is annoying.

 
Flag Post

Hi,

I too had this problem, but it was easily fixed in my case.
Go to the Chrom tab → Settings → Show advanced settings → Content settings → Select “allow local data to be set” under cookies.

This solved the problem.