WASD or Arrow Keys "stick" on moving games only on Kongregate - Problem solved, check the sticky! page 13

326 posts

Flag Post

Also RawrDawG07 – I have three flash plugins….

 
Flag Post

Also my keys are fine outside of using any flash games and the only keys that work in flash games for me on Chrome are the arrow keys.

 
Flag Post

Does this help any?

http://www.kongregate.com/forums/7/topics/241772?page=1#posts-5207540

 
Flag Post

Kind of but i’m stuck because I have three flash plugins and I’ve searched like everywhere and still haven’t found a way to fix this with three flash plugins…

 
Flag Post
Originally posted by shadowlord97:

Kind of but i’m stuck because I have three flash plugins and I’ve searched like everywhere and still haven’t found a way to fix this with three flash plugins…

Never heard of that kind of situation before. o.O Hopefully someone else can provide some insight.

 
Flag Post

Well it appears that the keys don’t stick and that they just don’t work anymore in flash games with google chrome version 20 and i’d rather have it not work than have sticky keys but hopefully I can fix this situation now by trying what everyone else is doing!!

 
Flag Post

And of course it doesn’t work _

 
Flag Post
Originally posted by shadowlord97:

And of course it doesn’t work _

Reinstalling Chrome doesn’t help any?

 
Flag Post

Nope :D

 
Flag Post
Originally posted by shadowlord97:

Nope :D

Have you already tried reinstalling your adobe flash player?

 
Flag Post

No, but I update it whenever an update is available… i’ll try reinstalling it

 
Flag Post

There’s apparently an experimental flash player I have in my browser using the code PPAPI I think that’s why it’s messing everything up but I don’t know how to uninstall it because there are no documents online on how to…

 
Flag Post

I have found out that it is just IE8 or Firefox. I have Google Chrome and it seems to be doing fine.

 
Flag Post

It’s not…… _ did you read any of the last comments….

 
This post has been removed by an administrator or moderator
 
Flag Post

the keys stick on me too and i use both chrome and IE9. turned protection off and everything

 
Flag Post

I have this problem too, I play on my laptop. I notice that if I connect a keyboard in the USB port, the keys don’t seem to “stick” anymore. And yes, it only does this on Kongregate.

 
Flag Post
Originally posted by PokemonFan7:

Look everyone in this thread is just posting the same thing over and over. Look the problem is probably windows explorer 8. The solution is:
1.go into tools
2.click on internet options
3.go to the security tab
4.click trusted sites
5.make sure the “enable protected mode”(or something like that) is un-checked
6.add kongregate as a trusted site
done
Believe me, I had the “sticky keys problem” but this fixed it.

Originally posted by chriskallen1:

I think I’ve drilled to the core of the problem. I’ve encountered the same problem for a long time, and the fact that it persists across browsers, across platforms, etc. makes me think it’s related to how Flash fundamentally processes keyboard input.

Speaking as a Flash developer, I’ve found keyboard latency issues pop up under very specific circumstances. Most of the time, Flash programmers have event listeners trap keyboard “KEYDOWN” events. I was not sure at first whether these events log only once (for the initial keypress) or log a whole bunch of times (based on the typematic rate and delay).

Turns out, it’s the latter. When you hold a key, you’ll get literally hundreds of repeated events stuffed through the queue, just waiting to be dispatched to the listeners. But why is this a problem only some times and not others?

Well, during the development of my first game (Atheist Armageddon), I found that this issue was negligible to nonexistent…until I started adding more objects and more listeners. Once that happened, there was more stuff to display on the screen and more input to check for. And that’s when the issue, previously not present, suddenly became quite serious. I should note this issue appeared in Adobe’s own player—NOT in a browser.

The culprit, it seems, is how Flash reads and dispatches messages to event listeners. Real-time code expects keyboard events to be dispatched and handled almost immediately, but Flash takes a different approach, spanning the dispatch of a large number of keyboard events over multiple frames. The events will EVENTUALLY get dispatched, and in the correct order…but several frames too late, pissing all of us off!

The “spanning input queue across multiple frames” issue will tend to crop up when there’s more stuff in the background that needs to be processed, drawn, etc. This explains why tweaking some performance settings can alleviate the problem sometimes, but not always.

How to fix this? Well, Flash programmers should be aware of this from now on. But seeing as I can’t force every Flash developer in the world to recompile and republish their projects, here’s a radical but effective solution. Go into your Control Panel, open up the Keyboard settings, and reduce the Repeat Rate to a much lower amount. This means fewer KEYDOWNs forced through the event listeners, and less of a chance the events will span multiple frames. Worked for me!

Just don’t forget to knock the Repeat Rate back up when you want to type something like “-—————-”. :-)

These are the suggested remidies. Second worked for me.

 
Flag Post

Didn’t work :D

 
Flag Post

Finally fixed it! If you have Comcast uninstall the “Constant Guard” thing and restart your computer and it will work again, fo sho!

 
Flag Post

i thot it was sticky keysss
thxxx

 
Flag Post

To get the beeping sounds on, you click the shift key 5 times! And to get it to go off, you click shift 5 times again! Yall will probably find this on more helpful cuz some o’yal people are dumb! Thanks, Me!

 
This post has been removed by an administrator or moderator
 
Flag Post

I have the exact same problem and its really pissing me off. I used to love playing on kong but now its not enjoyable in the least bit because of this problem

 
Flag Post
Originally posted by Ventero:
dawnofwar, did you try this fix?

Originally posted by bbiernat:
SOLVED:
Tools—-Internet Options - Security tab - uncheck protected mode.
or
Tools—-Internet Options - Security tab - click -trusted sites – click sites – uncheck require server – click add
(Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add.
This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem.
Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4.
Good Luck!

lag