WASD or Arrow Keys "stick" on moving games only on Kongregate - Problem solved, check the sticky! page 5

329 posts

Flag Post

vista gives off dozens of problems but not always serious things some small things like minor bugs or something just be careful what u do they can end up permenent.

 
Flag Post

BBiernat’s way worked fo me!!!!!!!!! OMG thank you!!!

 
Flag Post

It seems to me like this is a problem caused by a lot of things clashing, anyone think of reporting this to the actual companies? Then they may be able to find a fix and include it in the new update, if we all sent them this link in a report(along with a summary), it may do something.

Most likely, it seems to be Flash clashing with Vista’s security system, Im on IE7 and Vista and I havent had this problem yet so yeah, none of us really know how to work with coding and whatnot im guessing, we would need to ask the proffessionals that made it, right? I just cant even start to imagine what bug between a program and a game would affect a keyboards input, especially to make it repeat like that…

 
Flag Post

yea, probably a dead thread but im having this problem and cant figure out what’s wrong. happens in thing thing, medieval rampage, etc…

 
Flag Post

If you’re using IE, read this post

 
Flag Post

ty! that helped a lot! i only got like 1/4 of the way on hat factory before i used this thread and the first time i did those changes, i got it on my first try.

 
Flag Post

Maybe the reason you people are having problems with WASD and arrow keys is because of your browser;
if u don’t have Mozilla Firefox then install it (used to have the same issue, friend told me to install Mozilla Firefox and
was able to enjoy playing my favorite games such as Learn To Fly and Hands of War)

 
Flag Post
Originally posted by Ventero:

If you’re using IE, read this post

And if I’m using Firefox, what should I do?

I’ve already tried eyedol’s method and I know re-installing flash player won’t do any good.

 
Flag Post

I just noticed that although a town’s worth of people are experiencing this,Nobody AT ALL has mentioned anything wrong with the letter or number keys APART from the wsad keys.And even then the wasd keys do not stick at all when writing.If the wsad keys are perfectly fine for typing,why do they get jammed when playing?

 
Flag Post
Originally posted by bbiernat:
SOLVED: Tools---Internet Options --- Security tab --- uncheck protected mode. or Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add. This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem. Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4. Good Luck!
just to clarify if i have kongregate as a trustd site and turn protect mode ON will it still stop the problem?
 
Flag Post

i think this is the same prob ive been having and if you just tap the key thats stuck a couple times it will unstick it but it doesnt block the stick from happenign

 
Flag Post

Note that this has nothing to do with physical sticking. For some reason the message from the key is getting held up somewhere by internet explorer and causing games to think they’re still being pressed when they’re not (like they are stuck down). If you’re in Firefox then you have a different problem (and I’m not sure what – I haven’t seen reports of this outside of IE).

sirchandestroy – Yes, I believe if you turn it into a trusted site it should work with protected mode on.

 
Flag Post

I got exaclty the same problem, but not on Kongregate. Thanks, bbirenat!
Also, see:

http://www.kongregate.com/pages/help#keyssticking

- bilde2910

 
Flag Post

i had the same problem and it only happened on kongregate,idk if somebody suggesed this as i havent read all of the posts but i was using IE before, and playing these games on firefox fixed this for me

 
Flag Post

OMG OMG I FREAKEN LOVE YOU BBiernat XD

for every to know.

tool—internet option— sercurity tab—uncheck protect mode

 
Flag Post
Originally posted by bbiernat:
SOLVED: Tools---Internet Options --- Security tab --- uncheck protected mode. or Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add. This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem. Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4. Good Luck!
Worked great, thanks.
 
Flag Post

It is a great possibility that it is IE 8 because this never happened before i downloaded that

 
Flag Post

JUST LIVE WITH IT, its not a big deal it happens to me to but its easy to live with.

 
Flag Post

Always happens to me. No matter what site I go on, my keys stick. I’ll try this.

 
Flag Post

thats great and all, but what if you dont have tools?

 
Flag Post

Im also have the same thing happen im on IE8 on win 7 Laptop keybored brand new sticky keys are off

 
Flag Post

Also ir just stays going left or right wont change tryed that fix didnt work

 
Flag Post
Originally posted by pilotclan9404:

Also ir just stays going left or right wont change tryed that fix didnt work

Have you tried this?
Originally posted by bbiernat:
SOLVED:

Tools---Internet Options --- Security tab --- uncheck protected mode.

or

Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add.

This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem.

Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4.

Good Luck!
 
Flag Post

Wish I’d found this thread before shelling out for a new keyboard. Happened to me on loads of games at various sites.

I’ve tried the workaround and it seems to work on IE8, and I downloaded Chrome and everything works fine with it too. Guess it depends whether or not you want to mess around with your security settings. I don’t know enough about it so Chrome is the easy solution for me cheers

 
Flag Post

I HAVE IE7 SAME PROBLEM IT DRIVES ME INSANE i tried reinstallin adobe flash same problem my pet protector is the game i first noticed lately it has happened once b4 with some elevator game cant remember wat its call though any suggestions on how to fix it? im on a powerful laptop about 6 months old