WASD or Arrow Keys "stick" on moving games only on Kongregate - Problem solved, check the sticky! page 6

329 posts

Flag Post
Originally posted by bbiernat:
SOLVED:

Tools---Internet Options --- Security tab --- uncheck protected mode.

or

Tools---Internet Options --- Security tab --- click -trusted sites - click sites - uncheck require server - click add (Make sure you also have unchecked protected mode for this zone) This will disable it for only the site you add.

This solved the problem but obviously will weakens your security. I would recommend you only disable this when you go to sites you trust that have this problem.

Tested with IE8 on Windows 7 RC. I also think it will work with Vista and IE 7. I tested with the game shift 4.

Good Luck!
 
Flag Post

YES! Adding http://kongregate.com to my trusted sites in IE Tools > Security did the trick. Thank You to all who posted!

 
Flag Post

They need a sticky for this.

 
Flag Post

Good point. Done and done.

 
Flag Post

I also have this problem. I just got a new laptop too. HP 64bit Vista business. It’s really annoying.

 
Flag Post
Originally posted by 4ss4ssin:

I also have this problem. I just got a new laptop too. HP 64bit Vista business. It’s really annoying.

http://www.kongregate.com/forums/7-technical-support/topics/67250-fix-for-keys-sticking-in-games-in-internet-explorer

 
Flag Post

I have modified the first post of this thread to point to that other thread. Hopefully people will see that now and not feel the urge to post here too. I’m tempted to lock the thread, but it’s been so helpful that I don’t want people to get stuck and not find the other one…

 
Flag Post
Originally posted by dededock:

hey everyone READ THIS, to solve this problem you gotta press shift key 5 times and ACTIVATE sticky keys when that popup shows up.
i dont know why it works like that but it still solved my problem ;)
oh, and i have windows 7, just to tell you guys that this is not a vista problem

i have vista and it still does it, stupid IE8 i knew i shouldnt have downloaded it

 
Flag Post
Originally posted by Hoodlem:
Originally posted by dededock:

hey everyone READ THIS, to solve this problem you gotta press shift key 5 times and ACTIVATE sticky keys when that popup shows up.

i dont know why it works like that but it still solved my problem ;)

oh, and i have windows 7, just to tell you guys that this is not a vista problem

i have vista and it still does it, stupid IE8 i knew i shouldnt have downloaded it

Take a look at this topic please ;)

 
Flag Post

I think I’ve drilled to the core of the problem. I’ve encountered the same problem for a long time, and the fact that it persists across browsers, across platforms, etc. makes me think it’s related to how Flash fundamentally processes keyboard input.

Speaking as a Flash developer, I’ve found keyboard latency issues pop up under very specific circumstances. Most of the time, Flash programmers have event listeners trap keyboard “KEYDOWN” events. I was not sure at first whether these events log only once (for the initial keypress) or log a whole bunch of times (based on the typematic rate and delay).

Turns out, it’s the latter. When you hold a key, you’ll get literally hundreds of repeated events stuffed through the queue, just waiting to be dispatched to the listeners. But why is this a problem only some times and not others?

Well, during the development of my first game (Atheist Armageddon), I found that this issue was negligible to nonexistent…until I started adding more objects and more listeners. Once that happened, there was more stuff to display on the screen and more input to check for. And that’s when the issue, previously not present, suddenly became quite serious. I should note this issue appeared in Adobe’s own player—NOT in a browser.

The culprit, it seems, is how Flash reads and dispatches messages to event listeners. Real-time code expects keyboard events to be dispatched and handled almost immediately, but Flash takes a different approach, spanning the dispatch of a large number of keyboard events over multiple frames. The events will EVENTUALLY get dispatched, and in the correct order…but several frames too late, pissing all of us off!

The “spanning input queue across multiple frames” issue will tend to crop up when there’s more stuff in the background that needs to be processed, drawn, etc. This explains why tweaking some performance settings can alleviate the problem sometimes, but not always.

How to fix this? Well, Flash programmers should be aware of this from now on. But seeing as I can’t force every Flash developer in the world to recompile and republish their projects, here’s a radical but effective solution. Go into your Control Panel, open up the Keyboard settings, and reduce the Repeat Rate to a much lower amount. This means fewer KEYDOWNs forced through the event listeners, and less of a chance the events will span multiple frames. Worked for me!

Just don’t forget to knock the Repeat Rate back up when you want to type something like “-—————-”. :-)

 
Flag Post

That doesn’t explain why it only happens on Kongregate and in IE.

 
Flag Post

I have no idea why it would only happen on some websites or in certain browsers. And I’ve read all the replies; it happens in FireFox too. And in Adobe’s own standalone Flash player. And on a variety of other sites, not just Kongregate.

Remember, three factors are critical here:
1) How the Flash program was developed. higher framerate=more likely; more to display=more likely; poor input handling=more likely.
2) How Flash version implements event dispatch. Different versions and different plug-in builds are a likely influence. Sorry; don’t know which ones.
3) More stuff running in the background=more likely; security settings and AV protection=more likely; less powerful hardware=more likely.

Having said this, I find it totally unacceptable that Adobe forces AS3 programmers to rely on events with unreliable queue handling. Unless any other developer knows of a workaround?

 
Flag Post

I hate people who say “Turn off syicky keys”

Everyone who has this problem turns it off and it dosent work!!!!! (I have the same problem)

 
Flag Post
Originally posted by pokem0nfan134:

I hate people who say “Turn off syicky keys”

Everyone who has this problem turns it off and it dosent work!!!!! (I have the same problem)

http://www.kongregate.com/forums/7-technical-support/topics/67250-fix-for-keys-sticking-in-games-in-internet-explorer

 
Flag Post

Look everyone in this thread is just posting the same thing over and over. Look the problem is probably windows explorer 8. The solution is:
1.go into tools
2.click on internet options
3.go to the security tab
4.click trusted sites
5.make sure the “enable protected mode”(or something like that) is un-checked
6.add kongregate as a trusted site
done
Believe me, I had the “sticky keys problem” but this fixed it.

 
Flag Post
Originally posted by PokemonFan7:

Look everyone in this thread is just posting the same thing over and over. Look the problem is probably windows explorer 8. The solution is:
1.go into tools
2.click on internet options
3.go to the security tab
4.click trusted sites
5.make sure the “enable protected mode”(or something like that) is un-checked
6.add kongregate as a trusted site
done
Believe me, I had the “sticky keys problem” but this fixed it.

Good job! That fix has only been posted every other post!

 
Flag Post

For some reason, when I had Internet Explorer, it happened. But I installed Mozilla Firefox, and it works perfectly…

 
Flag Post

You guys listen to what chriskallen1 has to say ! 100% FIXED MY PROBLEM Thank you so much chris.. I became a member today just to say thank you! I have searched high and low. And you guys think about it , the security thing may work for some odd reason but what he said is fact.. I hack games daily for a site, and racing games especially would stick, on internet explorer, firefox , and here is the kicker, on my pc just through flash player with
my firewall on … So you see it has nothing to do with your browser.. I turned repeat delay to long and my repeat rate a little under halfway and Have played almost an hour not one time has my car kept spinning..Anyway whatever works for you guys but chriskallen1 knows what he is talking about, flash games use listners and toooo many lag your pc. And if you ever noticed your car or character will go on auto walking back and
forth up and down , thats the events trying to catch up…OK enough from me I am just
so happy finally a fix!!

 
Flag Post

the same thing is happing to me i have a fast internet connection just had my key board replaced and im redownloading flash now but it is stupit i tryed it on my big computer and it is slow as hell and it worked fine on games but my laptop is on all arrow keys and WASD besides robot rage

 
Flag Post
Originally posted by dellman12321:

the same thing is happing to me i have a fast internet connection just had my key board replaced and im redownloading flash now but it is stupit i tryed it on my big computer and it is slow as hell and it worked fine on games but my laptop is on all arrow keys and WASD besides robot rage

http://www.kongregate.com/forums/7-technical-support/topics/67250-fix-for-keys-sticking-in-games-in-internet-explorer

 
Flag Post

I don’t have that problem. I’m using Internet Explorer 7 and Safari.

 
Flag Post

I got the same problem, on Internet Explorer. But when I installed Fire Fox it worked! :D

 
Flag Post

But what if I have the problem in Firefox? Help!

 
Flag Post
Originally posted by Rezo2:

But what if I have the problem in Firefox? Help!

It shouldn’t happen in Firefox. The cause is most likely an add-on. Try starting in safe mode (so all add-ons are disabled) and see if it still happens.

 
Flag Post

Whenever i play games on Kong that use arrow keys for control(Shadowreign, boxhead, etc.), sometimes my character moves unstoppably one-way only(left, right, up, or down).
It happens on most Kong games that uses arrow keys for movement(WASD dont seem to have this problem, or at least for me).Can anybody tell me what’s actually going on Kongregate?