API strange message: [Konduit] [Game->Service]: hello: {"req.id":0,"client.ver":1}

9 posts

Flag Post

Hi, I’m hoping some of you more experienced kong api’ers can help me…

I tried adding the stats API to our game using QuickKong, and it seems pretty straightforward, but when I look at the game’s java console output (after adding ?debug_level=4 to the game’s path), I see this instead of a clear success message:

[Konduit] [Game→Service]: hello: {"req.id":0,client.ver

Anyone know what I could be doing wrong here or what this message actually means? Any help would be appreciated, thanks!

 
Flag Post

Never seen that but pretty interesting. The hello message is promising though, it means that your game successfully connected with the Konduit system (Kong’s API). I personally haven’t used debug_level in a long time, but if you are getting messages printed out when stats are submitted I would assume everything is working fine.

Also, thanks for using QuickKong. Send me the game URL when its published and I can put it on the “Games that use QuickKong” list.

 
Flag Post

Thanks for the response, UnknownGuardian (and for QuickKong!), but it seems it’s not working – we’re still only getting 25% revenue after a couple days of my implementation of the API. :/ It’s strange because in offline (shadow) testing everything looks just peachy. Btw I see the string got cut off for some reason in my post, so here it is again:

hello: { req.id,client.ver }

Does the kongregate API team monitor this forum by any chance, or should I try contacting them directly?

 
Flag Post

You’ll have to contact them directly, since they are usually super busy (or at least the people that work with the API) and generally aren’t browsing the forums.

Second, your message is getting cutoff because Kongregate’s textile is parsing it. "stuff":bla makes a clickable link, so just type the @ symbol before and after your message like such: @your printed message@.

Finally, the 25% rev share also appears for a lot of developers until enough scores have been submitted to kong for some reason. But I’d definitely contact Kongregate to make sure you are doing it right, especially if think you are going to have high traffic for your release.

 
Flag Post

I’m getting this too, and I’m not getting the “success:true” result back. Any help would be appreciated.

 
Flag Post

Maybe post your connection code here? Also, does the API seem to be working (the highscores part)?

Edit: Ha ha, just saw which game you made, so I guess you got the API working. I also see you weren’t using QuickKong, so it wasn’t a problem related to it.

 
Flag Post

Yep. I’m getting the same weird message. Konduit and statistics get initialized but then none of my statistics even attempt to submit? Anyone figure this out?

 
Flag Post

Do you have some code to post? Perhaps something got messed up.

 
Flag Post

http://pastebin.com/GTRfssFY
Here’s the debug info. I’m thinking maybe it’s something on the client side? Game doesn’t appear to be attempting to submit statistics, although it should.