Upload Game Problem

10 posts

Flag Post

I hope this is the proper place for this but I have uploaded a game (not yet published) and the Game Preview page is just blank.

It’s a flash 11.1 game using stage3d. It works perfectly on my website.

http://www.pickledbrain.co/FlashGames/Pixelomoeba/

Any reason why this would happen?

 
Flag Post

Try reuploading it. Prolly messed up somehow. Also test on a few browsers to ensure that its not some older FP version in x browser that is causing the issue.

 
Flag Post

Well I reuploaded the game (a couple of times) and it still works locally and online but I’m still getting a blank preview. I also tried firefox 14.01 and I’m typing this on Safari 5.1.7 and it is still blank.

Any other ideas? Either way thanks for the help Unknown

 
Flag Post

Want to PM me your guest access link (which you can get by appending /api to the end of the game url) and I’ll check it out?

 
Flag Post

Let’s see. I think I did this right.

http://www.kongregate.com/games/Stibs/pixelomoeba_preview?guest_access_key=7dc27a07d2c9d2d0fa2f072f5c5ec4174d522c763c5f1209297373388e18458b

Thanks a bunch Unknown

 
Flag Post

Looks like your game is embedded and should work. It is likely a problem of some code you have, perhaps a broken preloader or some sitelock code?

 
Flag Post

oops you said PM. lol My bad

 
Flag Post

Hmm. I don’t have any sitelock code. I’ll have to do some research on the preloader. I’m fairly new to flash.

 
Flag Post

Okay so I setup a working preloader. When I reuploaded and play the game the preview goes blank, then the preloader works for a flash, loads, and then it all goes blank again. So I guess it worked for a second there. I believe you are right Unknown it is something in the swf (maybe having something to do with redrawing?). But whatever it is why would it only affect kongregate? This works fine on my website. Could it have something to do with wmode=direct?

 
Flag Post

It might be. I don’t think kong uses wmode=direct yet, but I could be entirely wrong. If you are using FlashDevelop to develop this in, check out FlashConnect and start tracing stuff online to see where the issue occurs. FlashConnect allows you to use trace in the browser and have it output to FD.