Recent posts by MonkeyTree on Kongregate

Flag Post

Topic: Kongregate Multiplayer Games / [Fantasy Online] Official: FO Help and Support

I can’t play anymore! The game now seems to require Flash Player 11.5 which for a Mac requires OS X v.6 or better. My Mac OS cannot be upgraded past X v.4.

Why why why?