Recent posts by Razmoudah on Kongregate

Flag Post

Topic: Technical Support / Protector series

For some reason I get an error about a script causing flash player to run slow on ALL of the Protector series games. None of them will play for me. I have Flash Player version 11,1,102,63, using Mozilla Firefox, running on Ubuntu Linux.