Comments for Shootorial #5

avatar for swaghomestyle
swaghomestyle

Aug. 2, 2014

Under rating threshold (show) Hi :P

+ - !

(0)

avatar for poohbahthegrand
poohbahthegrand

Dec. 6, 2013

Under rating threshold (show) For whatever reason, my hitTest won work. All my code follows the tutorial exactly, but the ships and missiles just fly past each other. help?

+ - !

(0)

avatar for OUCHiambeingshot
OUCHiambeingshot

Nov. 19, 2013

Under rating threshold (show) for people having trouble getting their missiles to connect with other movie clips. Make sure that you are not typing enemy when you should be typing enemies and vice versa. Its easy to start getting them all confused,.

+ - !

(0)

avatar for OUCHiambeingshot
OUCHiambeingshot

Nov. 19, 2013

Under rating threshold (show) fixed it. I had to alter the animation itself. Not sure why though

+ - !

(0)

avatar for OUCHiambeingshot
OUCHiambeingshot

Nov. 18, 2013

Under rating threshold (show) I cant seem to get my explosion clip to play when an enemy ship is hit. my code is precise but still nothing

+ - !

(0)

avatar for nighttb
nighttb

Nov. 2, 2013

Under rating threshold (show) Thank you Coopasetic!! If your explosion animation is looping, and you can't figure out what's wrong, make sure your Explosion.as file is saved in the same folder as your main flash file.

+ - !

(0)

avatar for Starken
Starken

Nov. 1, 2013

Under rating threshold (show) Got same problem alean200, the missiles i shot is not doing anything, i can collide on them and they die.

+ - !

(0)

avatar for alean200
alean200

Aug. 6, 2013

Under rating threshold (show) Why my enemy ship don't explode when he hit me?? (4 page)

+ - !

(0)

avatar for Stalthdan
Stalthdan

Jul. 30, 2013

Under rating threshold (show) @Natthone maybe you're doing something wrong. You'll have to provide a little extra detail for me to be able to help you though.

+ - !

(0)

avatar for Natthone
Natthone

Jul. 29, 2013

Under rating threshold (show) I can't seem to put the explosion animation into my game. I can't put any animation into any of my games. Can someone help me?

+ - !

(0)

avatar for Stalthdan
Stalthdan

Jul. 2, 2013

Under rating threshold (show) @gortholomew make sure you did everything right, and pay extra attention to the pages 8, 9 and 10. If the problem still persists, send me a pm with your ship, enemy ship and missile code.

+ - !

(0)

avatar for gortholomew
gortholomew

Jun. 25, 2013

Under rating threshold (show) i did everything right until page 14. the enemies arent exploding when they get hit by missiles. i went back and rechecked everything but i cant find what i missed.

+ - !

(0)

avatar for drfill
drfill

May. 3, 2013

Under rating threshold (show) Great tutorial. However, the "Click here for more Shootorials" link doesn't work for me. Thought I'd share that so these bad links can be checked out and fixed...

+ - !

(-1)

avatar for mateo9121
mateo9121

Mar. 28, 2013

Under rating threshold (show) kuul

+ - !

(-1)

avatar for Biggums426
Biggums426

Jan. 26, 2013

Under rating threshold (show) line 47 error?!

+ - !

(-1)

avatar for Biggums426
Biggums426

Jan. 26, 2013

Under rating threshold (show) Sorry, it's properties you need.

+ - !

(1)

avatar for Biggums426
Biggums426

Jan. 26, 2013

Under rating threshold (show) CS6 users, on page 5 it is not linkage, but edit to change the options.

+ - !

(1)

avatar for Frostyfun
Frostyfun

Jan. 13, 2013

Under rating threshold (show) Hey everyone! If anyone here wants to convert AS2 code to AS3 I set up a quick guide on how to do it. This uses old code that you wont want in newer projects but the site I set up will explain how to use it! http://codingflashfast.webs.com/ !!!

+ - !

(0)

avatar for jheis
jheis

Nov. 9, 2012

Under rating threshold (show) Can anyone help me? My hitTest doesnt work I've been trying for 2 days. It looks like this: onClipEvent(enterFrame) { if (this.hitTest(_root.instancename)) { this.removeMovieClip(); } } can't see why it doesn't work. Help would be greatly appreciated.

+ - !

(0)

avatar for eronar
eronar

Nov. 2, 2012

Under rating threshold (show) Download links is the Action Script Shootorial seems to work, use those files if you need them: http://www.kongregate.com/games/Moly/shootorial-1-actionscript-3

+ - !

(0)

avatar for bitterlove
bitterlove

Oct. 31, 2012

Under rating threshold (show) ****PROBLEM SOLVED**** If your missile is killing enemies without hitting it as soon as it gets fired, check in the "Missile.as" file, find the "onEnterFrame()" function, and take a look at the "if" condition inside the "for...in" loop; at the end of the condition declaration there shouldn't be any ";". Example: THIS IS WRONG if (this.hitTest( _root.hero.enemies[i] )) // NO ";" IN THE END { //SOME CODE }

+ - !

(0)

avatar for bitterlove
bitterlove

Oct. 31, 2012

Under rating threshold (show) sorry guys, i have a problem with the " hitTest() " function. I checked the cod a billion time, but everytime my hero ship fires a missile, the bullet appears for a millisec and vanishes, and ANY enemy is destroyed (despite of its "_x" and "_y"). Basically, the missiles are fired and make the enemy explode as soon as they're fired, without phisically hitting it.

+ - !

(0)

avatar for ironjeger
ironjeger

Oct. 20, 2012

Under rating threshold (show) pliz help. download in this tutorial didnt work, thanks

+ - !

(0)

avatar for KrazyKarasu
KrazyKarasu

Oct. 11, 2012

Under rating threshold (show) Silly me, i put the explosion function in the onEnterFrame function, no wonder it wasn't working

+ - !

(0)

avatar for vector1
vector1

Sep. 28, 2012

Under rating threshold (show) If you loaded the downloadable source and your missiles won't hit anything, go to Control > Clear Publish Cache and Test Movie.

+ - !

(0)

avatar for sthreet300
sthreet300

Sep. 26, 2012

Under rating threshold (show) for some reason the this.hitTest(_root.ship) if statement won't return true... it is in the onEnterFrame function... anyone have any idea what is going wrong?

+ - !

(0)

avatar for brannum
brannum

Sep. 4, 2012

Under rating threshold (show) hi

+ - !

(0)

avatar for Growing_Hand
Growing_Hand

Aug. 29, 2012

Under rating threshold (show) Vind777 made a very useful comment, i tried ages to figure out, that it is only working with a different instant name.

+ - !

(0)

avatar for DoctorMoose
DoctorMoose

Aug. 21, 2012

Under rating threshold (show) My ship only seems to collide with the oldest instance of any enemy ship. If the enemy flys into me while im still, it explodes. If we hit while im moving, then not only it, but all the instances of the enemy explode. I can not understand why this is happening. Any ideas? Also, only the oldest instance of enemy ship detects my missiles, the shots ignore the younger instances. What the heck??!

+ - !

(-1)

avatar for Coopasetic
Coopasetic

Jul. 31, 2012

Under rating threshold (show) If your explosion animation is looping, and you can't figure out what's wrong, make sure your Explosion.as file is saved in the same folder as your main flash file.

+ - !

(0)

avatar for Gheata
Gheata

Jul. 30, 2012

Under rating threshold (show) haha, this shootorials still rock!

+ - !

(-1)

avatar for dnorman41
dnorman41

Jul. 22, 2012

Under rating threshold (show) Thanks guys got link to work

+ - !

(-1)

avatar for dnorman41
dnorman41

Jul. 22, 2012

Under rating threshold (show) Click here to download source files does not work for me can anyone send me the files or post on a ftp?

+ - !

(0)

avatar for Filippo2bt
Filippo2bt

Jul. 16, 2012

Under rating threshold (show) Thank you kongregate! Hey guys this is the game half completed I didnt have time to completed correctly but if you guy want to check it out this is the link: http://www.kongregate.com/games/Filippo2bt/spaceknight the art was also made by me thats why it took me a little more time and also please any help comment. Enjoy! :)

+ - !

(0)

avatar for azhrak
azhrak

Jun. 20, 2012

Under rating threshold (show) anyone have a code that speeds up the enemy spawn timer gradually?

+ - !

(1)

avatar for son_o_lilith
son_o_lilith

May. 22, 2012

Under rating threshold (show) Man I'm so Stupid!! I typed var enemies instead of var enemy. LOL my bad.

+ - !

(1)

avatar for son_o_lilith
son_o_lilith

May. 22, 2012

Under rating threshold (show) Same with Markonan here, the array puts me in error. And I don't think the instance name '_root.ship' is the problem. Actually, I found an error window right beside the timeline window, "There is no property with the name 'enemy'" it says. I have little idea what it means, can somebody help?

+ - !

(1)

avatar for Oreon_Necris
Oreon_Necris

Apr. 26, 2012

Under rating threshold (show) I feel like everytime i change something in my ship code everything stops working :( the ship doesn't move or shoot anymore and no enemies spawn or shoot or anything! I've been pawing over the code all day and nothing seems to be wrong with it... can someone help? pm me or something i beg of you! :p

+ - !

(1)

avatar for den1983
den1983

Apr. 25, 2012

Under rating threshold (show) i have this problem.. after i have added the collision between missile and enemy ship th rate of fire of hero ship change.. when the test begin it's only one missile but some enemy after it's 2 3 4.. any solution?

+ - !

(1)

avatar for Markonan
Markonan

Apr. 12, 2012

Under rating threshold (show) I get an error when I put the array into my code. When "enemies = [];" is put into my code the enemies stop spawning, bullets won't fire, and the background doesn't move like it's supposed to. I altered the gameplay slightly (ships coming from random locations, top to bottom, left to right, etc., bullets shooting all directions, and background moving with the ship instead of only horizontally) but no changes that I can think of that would alter it enough to do this. I tried it without the "enemies = [];" (and the "var enemies;" still created) and I don't have any problems whatsoever. I also tried it by doing "enemies = new Array();" but got the same issue. Any ideas?

+ - !

(1)

avatar for WindDragonLord
WindDragonLord

Mar. 29, 2012

Under rating threshold (show) @EphY You have to right-click open in new tab.

+ - !

(0)

avatar for EphY
EphY

Mar. 17, 2012

Under rating threshold (show) Neither Firefox nor Internet Explorer is allowing me to download the source files. Could somebody PM me a direct link?

+ - !

(2)

avatar for Schreib
Schreib

Mar. 10, 2012

Under rating threshold (show) It's a pretty good tutorial. I this it's the best actionscript tutorial I've ever seen personally, so thanks!

+ - !

(1)

avatar for Fishdawg
Fishdawg

Mar. 8, 2012

Under rating threshold (show) This tutorial is lacking in its explanation of a for... in loop. How exactly does it work? I see it's in the onEnterFrame method so for each frame does it check the entire array?

+ - !

(2)

avatar for del7318287
del7318287

Mar. 6, 2012

Under rating threshold (show) Ok sorry, I'm not totally incompetent but I need more help. So I figured out how to change the instance name. It is now the same as the ship name. All seems to be in order yet still my ship will not move, shoot, and enemy ships will not enter the screen. No error's are being reported in the log below the stage. And my coding is set exactly as is shown in the tutorial. I've come across some set backs while doing this, but this is by far the toughest one. I can't figure this out.

+ - !

(0)

avatar for del7318287
del7318287

Mar. 6, 2012

Under rating threshold (show) Ok I figured out my problem. I misspelled my instance name, but I can't find out how to edit it. I'm using flash cs5. So it might be a bit different layout wise from cs3. When I click on my ship and go to properties, under the name it says "instance of: my misspelled ship name. I cannot click on the name to edit it. It seems like it's locked. Anyone know?

+ - !

(0)

avatar for del7318287
del7318287

Mar. 6, 2012

Under rating threshold (show) So I did the first step of this tutorial. I gave my ship an instance name. (Same name as my ship). And since then everything has stopped working. When I run my test my ship will not move, shoot, and the enemy ships will not run. Everything was running perfectly before. And now when I select my my ship and go to properties, there isn't an option to change the instance name anymore?? I want to remove it to see if everything will run fine again. For good measure i continued to step 5 of the collision tutorial and it tells me to run the test and everything should working up to this point but it still doesn't work. Any ideas? Thanks

+ - !

(0)

avatar for fortymiletown
fortymiletown

Mar. 5, 2012

Under rating threshold (show) I made the instance name different from the class name of the ship, but I keep getting the error message "this statement is not permitted in a class definition"

+ - !

(0)

avatar for hannesdelbeke
hannesdelbeke

Feb. 20, 2012

Under rating threshold (show) ProTip: press v to get the selection tool

+ - !

(3)

avatar for Jonasinjo
Jonasinjo

Jan. 7, 2012

Under rating threshold (show) Please help, the enemy missiles spawn move about 10 pxles then freeze and disapper, and the hero ships missiles dosn't blow up the enemy ship, I have tried everything, but nothing works, I also have replacedthe original classes whit the classes from the download.

+ - !

(0)

  • add a comment